Apache doesn't start when mod the vhost file

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache doesn't start when mod the vhost file

Postby Heeter » 21. May 2010 15:39

Hi all,

I am trying to figure out why this is happening:

I do a fresh install of Xampp, I secure the xampp. I start all services and admins. Everything good at this point.

But when I mod the /extra/httpd-vhosts file & the httpd file (uncomment Load a vhost module, change server admin email address) I try to restart the apache admin, and it won't restart. I reboot several times, too.

I reinstall xampp, try again, and it does it again.

What am I doing wrong?

This is on a Windows XP Pro, with no other applications installed on it, all ports are free.

Heeter
Heeter
 
Posts: 7
Joined: 20. May 2010 17:16

Re: Apache doesn't start when mod the vhost fileI am baffled by

Postby BigWetDog » 21. May 2010 15:45

Check out this thread:
viewtopic.php?f=16&t=40575
And post your httpd-vhosts.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Apache doesn't start when mod the vhost file

Postby Heeter » 21. May 2010 16:41

Thanks BigWetDog,

Here it is:

Code: Select all
Listen 80

NameVirtualHost *:80

<VirtualHost *:80>
    ServerAdmin webmaster@hcctech.ca
    DocumentRoot "C:/xampp/htdocs/hcctech"
    ServerName hcctech.ca
    ServerAlias www.hcctech.ca
    ErrorLog "logs/hcctech.ca.log"
    CustomLog "logs/hcctech.ca-access.log" combined
    <Directory "C:/xampp/htdocs/hcctech">
      Options Indexes FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@albertainspector.com
    DocumentRoot "C:/xampp/htdocs/albertainspector"
    ServerName albertainspector.com
    ServerAlias www.albertainspector.com
    ErrorLog "logs/albertainspector.com.log"
    CustomLog "logs/albertainspector.com-access.log" combined
    <Directory "C:/xampp/htdocs/albertainspector">
      Options Indexes FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
</VirtualHost>



Heeter
Heeter
 
Posts: 7
Joined: 20. May 2010 17:16

Re: Apache doesn't start when mod the vhost file

Postby BigWetDog » 21. May 2010 17:06

Your vhosts look good.
First, check your configuration syntax by executing the following from the command line:
Code: Select all
C:\xampp\apache\bin\httpd -t

If there are no errors, then run
Code: Select all
C:\xampp\apache\bin\httpd -t -D DUMP_VHOSTS

and post it's output.
Also, have you checked your C:\xampp\apache\logs\error.log?
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Apache doesn't start when mod the vhost file

Postby Heeter » 21. May 2010 17:38

Hi BigWetDog,

I did adjust the Tomcat file, to no avail.

Here is the output:
Code: Select all
C:\Documents and Settings\Spare>C:\xampp\apache\bin\httpd -t -D DUMP_VHOSTS
VirtualHost configuration: wildcard NameVirtualHosts and _default_ servers:
_default_:443          localhost (C:/xampp/apache/conf/extra/httpd-ssl.conf:80)*:80                   is a NameVirtualHost
         default server hcctech.ca (C:/xampp/apache/conf/extra/httpd-vhosts.conf:5)
         port 80 namevhost hcctech.ca (C:/xampp/apache/conf/extra/httpd-vhosts.conf:5)
         port 80 namevhost albertainspector.com (C:/xampp/apache/conf/extra/httpd-vhosts.conf:20)
         port 80 namevhost localhost (C:/xampp/tomcat/conf/auto/mod_jk.conf:14)
Syntax OK

C:\Documents and Settings\Spare>


This is what I got on my error log:
Code: Select all
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs



Thanks again,

Heeter
Heeter
 
Posts: 7
Joined: 20. May 2010 17:16

Re: Apache doesn't start when mod the vhost file

Postby BigWetDog » 21. May 2010 17:50

Okay, good.
The good news is that your Apache configuration is fine. What you've got is another process listening on port 80.
Run the xampp port checker and see what it is that is listening on port 80.
It actually seems as though it may be apache itself, so check your task manager and see if you don't already have an instance running too.
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54

Re: Apache doesn't start when mod the vhost file

Postby Heeter » 24. May 2010 00:29

Thanks for your reply, BWD.

I did another fresh install.

I tried firing up apache with default settings again, all works. I pull up "It Works" from outside.

I try to mod the extra/vhost file alone, it craps out. I have checked all my network settings, checked the task manager, etc.

Baffled by what is going on.


Heeter
Heeter
 
Posts: 7
Joined: 20. May 2010 17:16


Return to XAMPP for Windows

Who is online

Users browsing this forum: Altrea and 52 guests