Sending mails from contact form via xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Sending mails from contact form via xampp

Postby bookie56 » 19. May 2010 19:56

Hi folks :D
I am new on the block and could do with some help. I have read umteen different docs about my problem but just getting more and more confused.

I have been working on rebuilding my site in Dreamweaver CS4 and have just created a contact form which i would like to test the mail on....

OK! Have Xampp installed and having trouble setting it up so that I can send mails from contact form.

My broadband supplier here in Sweden has smtp.bredband.net. I want to set up so that I can send mails to my gmail address.......

At the moment I keep getting faults and unsure if I need to setup mercury for this or is it just a case of configuring the php.ini file or is there more to be done.

Has anyone written a "how to" on this.


bookie56
bookie56
 
Posts: 10
Joined: 19. May 2010 15:39

Re: Sending mails from contact form via xampp

Postby JonB » 19. May 2010 22:24

It should be a php.ini fix

search for
[mail function]

fix this:

SMTP = smtp.bredband.net

optionally also fix the

;sendmail_from = postmaster@localhost

provided they use port 25 and do not require authentication, it should 'just work'

http://articles.sitepoint.com/article/a ... -email-php

brought to you by : "the wonders of Googling"

:roll:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Sending mails from contact form via xampp

Postby bookie56 » 20. May 2010 08:03

Hi JonB :D

Did I detect a little sarcasim in your post....LOL

OK! Point taken....googled my arse off but was so swamped with info didn't no where to turn.

Your info was right and it was right all along on my xampp aswell....the culprit was my "thankyou_form"...for some reason I had added a / to the code and that must have been when I was tired....LOL

It looks like this now $from_email = ""; and not $from_email = "/"; the script had been set up without the backslash!!

Now my mails go directly to my box :D

My fault!

I do thank you for your time!

bookie56
bookie56
 
Posts: 10
Joined: 19. May 2010 15:39

Re: Sending mails from contact form via xampp

Postby JonB » 20. May 2010 23:38

I'm glad its working

:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests