vhosts help.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

vhosts help.

Postby torniquet » 16. May 2010 01:19

Been at this for hours and i am stuck ¬¬

Here is what i have in my httpd-vhosts.conf file.

Code: Select all
NameVirtualHost *:80


<VirtualHost *:80>
   DocumentRoot "C:/Xampp/xampp/htdocs"
   ServerName localhost
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot "D:/webserver/test"
   ServerName test.localhost

   <Directory "D:/webserver/test">
      Options Indexes FollowSymLinks Includes ExecCGI
      AllowOverride All
      Order allow,deny
      Allow from all
   </Directory>
</VirtualHost>


i have added all the bits into the windows hosts file aswell.

restarted both computer and xampp several times.

and all i seem to be getting is the following...

Code: Select all
Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.
Error 403
test.localhost
16/05/2010 01:15:42
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1


anyone give me some idea on how to fix this prob?

Thanks Torni xx

Edit ~~

i have checked the folders... and all is right... there is index files, none are read protected. its just being a pain in the backside.
torniquet
 
Posts: 3
Joined: 16. May 2010 00:56

Re: vhosts help.

Postby torniquet » 16. May 2010 22:06

bump?

anyone know what might be going on?
torniquet
 
Posts: 3
Joined: 16. May 2010 00:56

Re: vhosts help.

Postby nebulom » 17. May 2010 20:09

I have a related problem. I want to have localhost access to xampp/htdocs and wecs.localhost to c:\system5\projects. I have this vhost

Code: Select all

<VirtualHost *:80>
   DocumentRoot "D:/xampplite/htdocs"
   ServerName localhost
</VirtualHost>

<VirtualHost wecs.localhost>
    DocumentRoot "C:/System5/projects"
    ServerName wecs.localhost
   <Directory "C:/System5/projects">
      Options Indexes FollowSymLinks
      AllowOverride All
      Order allow,deny
      Allow from all
   </Directory>
</VirtualHost>

But when I access localhost and wecs.localhost it still access to c:\system5\projects. Any help on this one? Thanks.
nebulom
 
Posts: 2
Joined: 01. April 2009 04:03

Re: vhosts help.

Postby BigWetDog » 18. May 2010 14:21

torniquet try adding this Before your NameVirtualHost directive:

Code: Select all
<Directory D:/webserver>
  Order Deny,Allow
  Allow from all
</Directory>


nebulom see this post:
viewtopic.php?f=16&t=40575
User avatar
BigWetDog
 
Posts: 148
Joined: 25. February 2010 15:54


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests