php.ini not setting Max Execution Time

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php.ini not setting Max Execution Time

Postby PC_Nerd » 11. May 2010 22:58

Hi,
I'm running xampp 1.73 win32, I've modified C:\xampp\php\php.ini to set max_execution_time as per the coe snippet below, but I still receive the "60 seconds execution time exceeded" error in my script.
I have run a full reboot and therefore restart of xampp.
Can anyone offer a suggestion to increase execution time ?

Thanks,
PC_Nerd

Code: Select all
   1.
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds
; http://php.net/max-execution-time
; Note: This directive is hardcoded to 0 for the CLI SAPI
max_execution_time = 180

; Maximum amount of time each script may spend parsing request data. It's a good
; idea to limit this time on productions servers in order to eliminate unexpectedly
; long running scripts.
; Note: This directive is hardcoded to -1 for the CLI SAPI
; Default Value: -1 (Unlimited)
; Development Value: 60 (60 seconds)
; Production Value: 60 (60 seconds)
; http://php.net/max-input-time
max_input_time = 60
PC_Nerd
 
Posts: 5
Joined: 20. January 2008 00:38

Re: php.ini not setting Max Execution Time

Postby JonB » 15. May 2010 00:01

Two things?

Is PHP running in safe mode?

Also check this tip:

http://us2.php.net/set_time_limit

Good Luck
:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: php.ini not setting Max Execution Time

Postby Goooood » 29. May 2010 18:28

same here, apache restarted, full reboot, phpinfo shows the correct max execution time which I set to 86400 seconds, but I still get the 60 seconds error

were you able to solve this problem?
Goooood
 
Posts: 2
Joined: 29. May 2010 18:26

Re: php.ini not setting Max Execution Time

Postby JonB » 29. May 2010 19:24

here's a tip:

To find out the currently set time limit, use

<?php
ini_get('max_execution_time');
?>

If set_time_limit has been previously called in the script, the result will be the value which was passed to set_time_limit (and not, as the function name "ini_get" appears to suggest, the value from the php.ini file).
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: php.ini not setting Max Execution Time

Postby menchbark » 24. June 2010 17:47

The solution to your problem is to raise the value of max_input_time as well.
menchbark
 
Posts: 1
Joined: 24. June 2010 17:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 64 guests