Сhange the php 5.3.1 to php 5.2.13

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Сhange the php 5.3.1 to php 5.2.13

Postby foras » 11. May 2010 06:59

Hello, how you can change the php 5.3.1 to php 5.2.13 in xampp 1.7.3 for windows?
Some modules in drupal 6 does not work correctly in php 5.3.x.
foras
 
Posts: 1
Joined: 11. May 2010 06:49
Location: Ukraine

Re: Сhange the php 5.3.1 to php 5.2.13

Postby MC10 » 23. May 2010 03:44

Install an older version of XAMPP that has PHP 5.2.13. I think that's XAMPP 1.7.1.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: Сhange the php 5.3.1 to php 5.2.13

Postby Altrea » 23. May 2010 14:38

XAMPP 1.7.1 is the last package with PHP 5.2 inside (PHP 5.2.9)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Сhange the php 5.3.1 to php 5.2.13

Postby vanburner » 19. September 2010 02:14

Same problem with Joomla! 1.5.20 so looks like back to Xampp 1.7.1
vanburner
 
Posts: 3
Joined: 19. September 2010 02:09
Location: Vancouver, BC

Re: Сhange the php 5.3.1 to php 5.2.13

Postby jekell » 13. November 2010 17:49

Just advising to try another version of XAMPP is useless.

The big question everyone is asking all around but no-one is answering to is the following :
Does XAMPP support a manual upgrade (or downgrade) of only one of it's elements : PHP or MySQL, etc ...

I've been loosing a lot of time on problems when trying to backup or reproduce online websites to finally discover that the root cause was that my local config was different
from the online config :
Take joomla for instance : it does not support PHP 5.3.X ! only 5.2.X will do
Everything works fine on my online site which is using PHP 5.2.14 ... but using 5.2.9 some pats of my site will not work ( function getimagesize not handling urls !)

But I have NO WAY to get a local web on my Windows PC that uses version 5.2.14 of PHP because there is no such XAMPP package.

I tried using other AMP packages, WAMPP Server : that enable to use several versions of PHP and MySQL in parallell, but when installaion of a joomla site was easy and immediate with XAMPP, I was not able to get it working straight away with WAMPP Server (probably .htaccess handling) ... and I don't feel like reading all tips&tricks and tweeking to be able to have up and running something that should be very simple.

XAMPP is the best AMP delivery I have been using in my searches (also tried easyphp) but I found nowhere someone giving instructions, tutorial or even advises on what should be done to upgrade/downgrade PHP only with a XAMPP installation.

I'm astonished this question doesn't appear in XAMPP's FAQ or docs ... even if the answer is NO.
jekell
 
Posts: 4
Joined: 13. November 2010 17:25

Re: Сhange the php 5.3.1 to php 5.2.13

Postby Altrea » 13. November 2010 18:33

jekell wrote:The big question everyone is asking all around but no-one is answering to is the following :
Does XAMPP support a manual upgrade (or downgrade) of only one of it's elements : PHP or MySQL, etc ...

This question is answered in every second thread where someone asking for upgrading one single component of the xampp package.

XAMPP DON'T SUPPORT UPGRADING OR DOWNGRADING ANY OF THE CORE SINGLE COMPONENTS !
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Сhange the php 5.3.1 to php 5.2.13

Postby JonB » 13. November 2010 19:29

But I have NO WAY to get a local web on my Windows PC that uses version 5.2.14 of PHP because there is no such XAMPP package.


ummm - yes, you do - simply install the packages standalone. Its really not all that difficult.

and here is the root of your problem

and I don't feel like reading all tips&tricks and tweeking to be able to have up and running something that should be very simple.

:lol:

I'm glad you think it should be so simple- we look forward to JekellAMP. (which will allow us to 'just install stuff')

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Сhange the php 5.3.1 to php 5.2.13

Postby jekell » 15. November 2010 21:10

Didn't mean to be unpleasant to anyone.

So let me apologize and repeat that XAMPP is the best AMP package i've been using ... because it is so simple to install and to get running.
Sorry also if I haven't found on the forum threads saying clearly XAMPP does not support manual upgrade of single Core elements.

Could someone point me to installation instructions for "packages standalone" ?
I guess PHP.net will only give indications for installing Apache+PHP ... and MYSQL for MYSQL&phpmyadmin.
Is there somewhere a global doc describing the different elements that should be installed, and the necessary steps ?

Thank you for your help.
jekell
 
Posts: 4
Joined: 13. November 2010 17:25

Re: Сhange the php 5.3.1 to php 5.2.13

Postby Altrea » 15. November 2010 21:26

The requirements are depending on the Software you want to run.

For example Drupal:
Drupal is written in PHP, so you need PHP
To serve the PHP pages you need a webserver (for example Apache HTTPD)
To hold the data you need a Database. MySQL Community Server is the recommend Database Management System.

To read about the requirements of Drupal, see here

Try Google to find a tutorial to bring them all together
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Сhange the php 5.3.1 to php 5.2.13

Postby jekell » 15. November 2010 23:13

What I want to do actually is to have a local web on my PC which is "as close as possible" to what my web hosting provider is giving and where I installed a Joomla 1.5.15.
(1&1) I'm not going to give the full phpinfo but basically I want the same versions for Apache, PHP and MySQL :

Config at 1and1
Platform: Linux
Apache: ???? (cannot get info)
PHP: 5.2.14
MySQL: 5.0.91
jekell
 
Posts: 4
Joined: 13. November 2010 17:25

Re: Сhange the php 5.3.1 to php 5.2.13

Postby JonB » 16. November 2010 14:36

When you install in standalone mode - the dependencies are lower, I'm fairly confident the only item you really need a 'dead-match' on is the PHP version.

The working assumption being that you install Apache 2.2.x and the current MySQL version. You'll probably want to install phpMyAdmin or you will need to learn the MySQL Admin tool that comes with a standalone installation (or get MySQL Workbench).

Altrea is the PHP guru, so I defer to his wisdom on my comment about 'I think PHP is the only real worry'... and, as he pointed out, you want to read the documentation/FAQ's for each product, as most have tip sheets for common integration tasks. I'd start with the PHP docs, as that is the critical part.

Good Luck, you will know a great deal more and save yourself lots of trouble down the road learning this stuff.

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Сhange the php 5.3.1 to php 5.2.13

Postby Altrea » 16. November 2010 15:03

JonB wrote:I think PHP is the only real worry

Nothing more to say :D . PHP-scripts depending very strictly to PHP versions, especially in the last time of hugh changes in the PHP core.

jekell wrote:What I want to do actually is to have a local web on my PC which is "as close as possible" to what my web hosting provider is giving and where I installed a Joomla 1.5.15.

In most cases it's enough to look for the Major and Minor version number of PHP. For example it does matter if you use PHP 5.2.X or 5.3.X, but it doesn't matter if you use PHP 5.2.9 or PHP 5.2.10.
In some cases minor releases have bugs in a function that make them incompatible to some webapplications (for example PHP 4.3.9, 4.4.2 or 5.0.4 are not supported by Joomla).
But all of that can be read in the technical requirements of the single webapplications.

Technical Requirements Joomla

What really matters is the PHP and Apache configuration. They can be very very different. If you want to come close to your online webhoster, then thats the point you should care about.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Сhange the php 5.3.1 to php 5.2.13

Postby jekell » 19. November 2010 23:10

Thank for your help

also adding this link to the thread :
http://www.thesitewizard.com/php/install-php-5-apache-windows.shtml

It's the kind I was looking for.
jekell
 
Posts: 4
Joined: 13. November 2010 17:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests