server/compiler error for http://localhost/

Problems with the Windows version of XAMPP, questions, comments, and anything related.

server/compiler error for http://localhost/

Postby nicoleta » 09. May 2010 08:31

I'm trying to install MediaWiki on Windows Vista Ultimate 64-bit via http://www.mediawiki.org/wiki/Manual:Ne ... on_Windows.
I was able to install XAMPP for Windows 1.7.2 successfully to the C:\ drive.
However, when trying to open http://localhost/ I get a "Server Error in '/' Application" "Compilation Error" with some additional technical details.
I think this might be because Apache doesn't seem to be running. On the XAMPP Control Panel, when I click [Start] for Apache, the text for Apache says "Apache started;" however, on MySql when I clicked [Start], it also said "MySql started," but the status next to MySql changed to "Running" and the button changed from [Start] to [Stop]. Apache still just says [Start] and no indication that it's running.
Can someone help me out to try to get XAMPP working properly so I can secure it (your help page says to go to http://localhost/security/) and install MediaWiki?
I'm trying to host a wiki-based website from my computer.
Last edited by nicoleta on 13. May 2010 07:31, edited 2 times in total.
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby nicoleta » 09. May 2010 12:54

Weird. It seems to be working now. Not sure why it wasn't earlier, perhaps just a temporary fluke or something.
"Congratulations: You have successfully installed XAMPP on this system!"
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby nicoleta » 11. May 2010 05:17

I got it working and was able to set up MediaWiki to much success, but now XAMPP is acting up again. Same issue, i.e. MySql is "Running" but Apache won't start. Perhaps it is a bug or something? Can someone tell me how I might be able to fix this, so Apache doesn't keep turning off?
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby Altrea » 11. May 2010 06:38

Do you use Software (IIS, Skype, some Windows Remote Software) that is blocking port 80 or 443?
Check your Apache error.log file for hints, what is going wrong there.
Check your ports with xampp-portcheck.exe or in your commandline with netstats -aon.
Maybe your Vista UAC doesn't allow you to open Apache ports. Start your xampp-control panel as Administrator.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: server/compiler error for http://localhost/

Postby nicoleta » 11. May 2010 16:35

I went through all the help files here. I'm running it as administrator, my ports are fine, I don't use Skype; everything seems to be ok. When I first installed it, it didn't work, then it started working fine for a day, and now it's not working again. It says "Apache started" when I click [Start] but doesn't say "Running" like MySql does. I don't know how to access the error log file, but I'm not sure if that'll help much. The annoying part is that this is apparently an inconsistent problem: it did work for a while. Here's the technical data when I try to open localhost, same as before:

Server Error in '/' Application.
Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0016: Could not write to output file 'c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.dll' -- 'Access is denied. '

Source Error:

[No relevant source lines]

Source File: Line: 0

Show Detailed Compiler Output:

c:\windows\system32\inetsrv> "c:\Windows\Microsoft.NET\Framework64\v3.5\csc.exe" /t:library /utf8output /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\6c8b43c3\00417696_0fe6c901\businesslogic.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\bf4185cc\009bd898_0fe6c901\UrlRewritingNet.UrlRewriter.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\fd6d2a51\006ea797_0fe6c901\TidyNet.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\78f9f4b0\006ea797_0fe6c901\MySql.Data.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\b900cc09\009bd898_0fe6c901\umbraco.standardFormhandlers.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\ad62e64a\009bd898_0fe6c901\VistaDB For Umbraco.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\5c0c4635\009bd898_0fe6c901\umbraco.XmlSerializers.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.Data.DataSetExtensions\3.5.0.0__b77a5c561934e089\System.Data.DataSetExtensions.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\272079df\006ea797_0fe6c901\Microsoft.ApplicationBlocks.Data.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\7a0c0fb4\00417696_0fe6c901\ICSharpCode.SharpZipLib.DLL" /R:"C:\Windows\assembly\GAC_64\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\06c997ed\00417696_0fe6c901\CookComputing.XmlRpcV2.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\84a04fb7\006ea797_0fe6c901\Lucene.Net.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Xml.Linq\3.5.0.0__b77a5c561934e089\System.Xml.Linq.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\e757200b\00417696_0fe6c901\IronMath.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\95b19d90\009bd898_0fe6c901\umbraco.providers.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\d0729ade\00417696_0fe6c901\interfaces.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.Runtime.Serialization\3.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\cea368e4\006ea797_0fe6c901\IronPython.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\771b5e3d\00417696_0fe6c901\cms.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\d0a25164\00417696_0fe6c901\ImageManipulation.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.WorkflowServices\3.5.0.0__31bf3856ad364e35\System.WorkflowServices.dll" /R:"C:\Windows\assembly\GAC_64\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\112967c7\009bd898_0fe6c901\umbraco.editorControls.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\0a380035\009bd898_0fe6c901\umbraco.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.ServiceModel.Web\3.5.0.0__31bf3856ad364e35\System.ServiceModel.Web.dll" /R:"C:\Windows\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\ac125e06\00417696_0fe6c901\DotNetOpenMail.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorlib.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\c1c0b584\009bd898_0fe6c901\umbraco.DataLayer.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\477260e2\009bd898_0fe6c901\VistaDB.NET20.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Core\3.5.0.0__b77a5c561934e089\System.Core.dll" /R:"C:\Windows\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\f0c4fadc\00417696_0fe6c901\controls.DLL" /R:"C:\Windows\assembly\GAC_64\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\84100c9e\009bd898_0fe6c901\umbraco.webservices.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\6d27b0e8\00417696_0fe6c901\AjaxControlToolkit.DLL" /R:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\assembly\dl3\48537ed8\009bd898_0fe6c901\umbraco.macroRenderings.DLL" /R:"C:\Windows\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll" /out:"C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.dll" /D:DEBUG /debug+ /optimize- /w:4 /nowarn:1659;1699;1701 /warnaserror- "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.0.cs" "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.1.cs"

Microsoft (R) Visual C# 2008 Compiler version 3.5.30729.1
for Microsoft (R) .NET Framework version 3.5
Copyright (C) Microsoft Corporation. All rights reserved.

error CS0016: Could not write to output file 'c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.dll' -- 'Access is denied. '

Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby nicoleta » 11. May 2010 16:50

I saw this for MySQL instead of Apache: viewtopic.php?f=16&t=40403
What's the difference between running and running as a service?? The MySQL is running fine, but I tried running the Apache as a service (clicking [Svc] then [Start]) instead of just clicking [Start] but to no avail. Perhaps I somehow did a wonky install and reinstalling will make it work again? Will I lose any of the data I entered on MediaWiki if I do that though?
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby Altrea » 11. May 2010 20:17

nicoleta wrote:When I first installed it, it didn't work, then it started working fine for a day, and now it's not working again. It says "Apache started" when I click [Start] but doesn't say "Running" like MySql does.
.. I don't know how to access the error log file, but I'm not sure if that'll help much.

Do you want to discuss with me about my error-finding methods, thats fine. "I can only show you the door. You're the one that has to walk through it."
That is a typicall describtion of this type of errors, which produce error-messages in the error.log file. This file can be found in xampp/apache/logs/.

nicoleta wrote:I'm running it as administrator

So, you rightclick -> run as Administrator the xampp cotrolpanel? Than thats fine.

nicoleta wrote:The annoying part is that this is apparently an inconsistent problem: it did work for a while.

Which is a hint for a blocked port, too. But the error.log file can tell you more.

nicoleta wrote:Here's the technical data when I try to open localhost, same as before:

Server Error in '/' Application.
Compilation Error
Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0016: Could not write to output file 'c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\e22c2559\92c7e946\App_Browsers.mzn6fex3.dll' -- 'Access is denied. '
...
Microsoft (R) Visual C# 2008 Compiler version 3.5.30729.1

I really don't like Microsoft Visual C# Compiler, because it tries to solve problems which aren't related to him or his programming language. (btw. Microsoft Compiler often comes with his own Webservers which can block ports too).

nicoleta wrote:I saw this for MySQL instead of Apache: viewtopic.php?f=16&t=40403
What's the difference between running and running as a service?? The MySQL is running fine, but I tried running the Apache as a service (clicking [Svc] then [Start]) instead of just clicking [Start] but to no avail.

Services run at very first with every Windows start. So they often run earlier than other programs which can block their ports.

nicoleta wrote:Perhaps I somehow did a wonky install and reinstalling will make it work again? Will I lose any of the data I entered on MediaWiki if I do that though?

You can give it a try, if you want. On Windows Systems with new UAC (Vista, 7, Server 2008) a run the XAMPP installer as administrator too. Don't know if this is needed.
Backup all, which is related to mediawiki (it is better to be safe than sorry) - sourcefiles, databases if already having some, etc.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: server/compiler error for http://localhost/

Postby nicoleta » 11. May 2010 20:36

Wow, ok, thank you. I found the error log, it says:
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
over and over and over.
I'm going to check [Svc] and restart my computer to see if that helps. Regarding the Port-Check, all the ports are listed as "free" except 80 (Apache HTTP) and 3306 (MySQL), which say "SYSTEM." I'm pretty sure it had the same port status when it was working, and I haven't done anything different that might make the port stop working. I noticed that when I restarted my computer earlier and opened the XAMPP Control Panel and clicked [Start] for Apache, it did go to "Running," but only for a brief moment, then went back to not working. So it looks like if it's a port issue, it's only being blocked after I attempt to run Apache? I'm by no means an expert on any of this, this is my first time using any sort of server software. Thanks for your help so far!
Regarding the MediaWiki content, I would be kinda pissed if I lost it :-(, it's only a day of work, but I wanted to use it to host class notes & materials, and doubt I could get the info again.
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby nicoleta » 11. May 2010 21:17

Whooo yay it works again :-D. Now for some backing up lol.
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA

Re: server/compiler error for http://localhost/

Postby Altrea » 11. May 2010 21:23

I wish you all the best :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: server/compiler error for http://localhost/ [solved]

Postby nicoleta » 13. May 2010 07:26

Yes, thank you. It's still working :-). I have it running as [Svc] now which solved the problem.
nicoleta
 
Posts: 9
Joined: 09. May 2010 08:19
Location: Maryland, USA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests