No XAMPP start page after enabling named vhosts?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No XAMPP start page after enabling named vhosts?

Postby oikram » 02. May 2010 12:46

Go to your httpd-vhosts.conf and add the following:

Code: Select all
<VirtualHost *:80>
 ServerAdmin webmaster@localhost
 DocumentRoot C:/XAMPP/xampp/htdocs
 ServerName localhost

 <Directory "C:/XAMPP/xampp/htdocs">
 Options Indexes FollowSymLinks Includes ExecCGI
 AllowOverride All
 Order allow,deny
 Allow from all
 </Directory>
</VirtualHost>


Now you can access your virtual hosts and if you do http://localhost or you click under admin on the menu, you will find the XAMPP start page as well.

Regards,
MEM
oikram
 
Posts: 3
Joined: 02. May 2010 11:52

Re: No XAMPP start page after enabling named vhosts?

Postby Frogmella » 02. May 2010 17:23

Thanks this was a great help, I was struggling to find out why local host wouldn't work for two days before I found this, now it does.

However, I still can't navigate along a path to open .php files in subfolders on the local host.

e.g. "http://localhost/htdocs/wordpress/wp-admin/install.php"

I always get "Object not Found..... Error 404" in i IE8. I have tried various different paths to different files and always get the same thing.

I am running Windows XP Pro SP3. This is a clean reinstallation of Windows especially for XAMPP.

I am very new to this as you might gather. Any ideas as to where I am going wrong?

Thanks in advance for any help
Frogmella
 
Posts: 3
Joined: 02. May 2010 17:11

Re: No XAMPP start page after enabling named vhosts?

Postby Altrea » 02. May 2010 22:08

Frogmella wrote:e.g. "http://localhost/htdocs/wordpress/wp-admin/install.php"

localhost automatically routes to your htdocs folder (or have you a htdocs folder inside your htdocs folder?)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: No XAMPP start page after enabling named vhosts?

Postby oikram » 02. May 2010 23:19

Altrea wrote:
Frogmella wrote:e.g. "http://localhost/htdocs/wordpress/wp-admin/install.php"

localhost automatically routes to your htdocs folder (or have you a htdocs folder inside your htdocs folder?)


I believe Altrea got it quite accurate. You don't need to type htdocs our your URL. Unless if you have a htdocs folder inside your htdocs folder, If you just do:
http://localhost/wordpress/wp-admin/install.php - you will probably find your .php file.


K. Regards,
MEM
oikram
 
Posts: 3
Joined: 02. May 2010 11:52

Re: No XAMPP start page after enabling named vhosts?

Postby Frogmella » 03. May 2010 10:03

Thanks again, doing as you suggest eliminated the 404 error, install still didn't run, but thats another problem altogether.
Frogmella
 
Posts: 3
Joined: 02. May 2010 17:11

Re: No XAMPP start page after enabling named vhosts?

Postby JonB » 04. May 2010 02:44

I seem to have lost the root of this question, what was the purpose of setting up vhosts in this context?

Is it to enable multiple hostnames? or is the intent to run multiple WordPress blogs?

Just trying to get my head around the reasoning.

Good Luck
:roll:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: No XAMPP start page after enabling named vhosts?

Postby Frogmella » 04. May 2010 10:08

I think it was to set up vhosts correctly so that when you type "localhost" into a browser you get the XAMPP admin screen. I had set them up incorrectly and "localhost" would only return a 404 error in the browser until I corrected the htppd-vhosts.conf file as shown in this thread.
Frogmella
 
Posts: 3
Joined: 02. May 2010 17:11

Re: No XAMPP start page after enabling named vhosts?

Postby JonB » 05. May 2010 15:27

What does happen when you enter http://localhost/worpress/wp-admin/install.php in your browser?

Sometimes, if the process started, but failed, its best to cleanout the WP folders AND the wp tables in MYSQL.

Good Luck
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests