Error after changing htdocs settings in httpd.conf

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error after changing htdocs settings in httpd.conf

Postby gnomixa » 23. April 2010 08:13

I changed these settings to:

DocumentRoot "D:\htdocs"
<Directory "D:\htdocs">

In my 1000 prior installations of Xampp that worked like a charm, but this time, I get an error:

Warning: file_put_contents(../../install/xampp_language.txt) [function.file-put-contents]: failed to open stream: No such file or directory in D:\htdocs\xampp\lang.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at D:\htdocs\xampp\lang.php:2) in D:\htdocs\xampp\lang.php on line 11

Surely, enough i went and changed the required line in my D:\htdocs\xampp\lang.php file to an absolute path pointing to the original installation located on drive C. Now every time I click on ANY language on XAMPP splash page, I get the splash page...


What do I need to change in order to point to a different htdocs path???? I feel like an idiot since I have installed this a million times, but I guess something was changed since then...but I can't find any documentation aside from changing these 2 settings in conf file, which I did. Just wasted an hour on something that used to take 3 minutes.

What do I do?
gnomixa
 
Posts: 4
Joined: 23. April 2010 08:05

Re: Error after changing htdocs settings in httpd.conf

Postby Narrowboyy » 23. April 2010 09:28

Unless you absolutely require the Welcome demo splash page for XAMPP then you can either rename that xampp folder or delete it anyway along with the 2 associated index files.

http://localhost/security goes to another location in the C:\xampp tree defined by an Alias directive in the httpd-xampp.conf file in the extras folder and it has it's own lang.php files.
So you can still access the security settings in XAMPP even after deleting or renaming the above xampp folder.

You can also edit the xampp_language.txt file in the install folder by changing to the language you require.
The language letters can be found in the htdocs\xampp\lang folder.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Error after changing htdocs settings in httpd.conf

Postby gnomixa » 23. April 2010 09:37

Thanks, i don't require a plash page:) however, it just seems that the package was put together sloppy.

By the way that file has the correct language ('en')....but the problem now is that I can't get past the splash page at all clicking on any language. So, how am I even supposed to get to these links (unless you didn't tell me, i wouldn't have known where the security is)....there is no documentation. What about other links?

so basically, it just blows...i hope the rest of the components are not sloppy like this. Xampp was a better product 2 years ago when I last installed it.
gnomixa
 
Posts: 4
Joined: 23. April 2010 08:05

Re: Error after changing htdocs settings in httpd.conf

Postby Narrowboyy » 23. April 2010 09:56

I agree entirely that this latest version 1.7.3 is the worst ever version released and one can only assume that Wiedmann has created an XAMPP that you are supposed to use only the defaults with.

If you want to stray from the defaults then you should be as clued up as he seems to think he is so you can try and fathom out his sloppy narrow minded coding "do what I say you should do or accept the consequences" is the way he sees things.

Prior versions or at least up to 1.7.1, were controlled by a different developer with only some scripts supplied and edited by Wiedmann but since he took over the whole development all hell has broken loose - BTW, he seems to have done a runner.


Once you delete both xampp folders in the htdocs folders and all index.php and index.html files that are associated with redirecting to the Welcome pages then you can't access the Welcome page and so have no need to change or edit the language files as the language files only effect the Welcome splash pages.

As I said the security pages have there own language files in C:\xampp\security\htdocs folder, so no need to do anything there when you access http://localhost/security

On the Welcome page the only links other than the security page are demos etc. of which you should be familiar by now and could do without them. ;)

Once cleared of the xampp folders in the htdocs folder you can proceed to place your own files and folders in there and all should be fine to move forward.

Fingers crossed and good luck.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Error after changing htdocs settings in httpd.conf

Postby gnomixa » 23. April 2010 16:43

aaaa, that explains it - new dev.

yes, my test php file works, so i think it should be ok, i wonder if there is a way to download old xampp...
gnomixa
 
Posts: 4
Joined: 23. April 2010 08:05

Re: Error after changing htdocs settings in httpd.conf

Postby gnomixa » 24. April 2010 01:12

downloaded version 1.6.8 from source forge and was running in 3 minutes!!!!!
gnomixa
 
Posts: 4
Joined: 23. April 2010 08:05

Re: Error after changing htdocs settings in httpd.conf

Postby Dark_Shadow » 24. April 2010 04:21

I had all this stuff installed separately and all was working well. Decided to give 1.7.3 a try, while I was redoing my server, honestly I think it's easier to install all of it separate than to deal with 1.7.3


I am gonna give 1.6.8 a try as well. Hope it's tat easy for me. :mrgreen:
Dark_Shadow
 
Posts: 5
Joined: 23. April 2010 03:22

Re: Error after changing htdocs settings in httpd.conf

Postby peter10 » 07. April 2014 17:54

Hi,

I have the same problem. When I open the directory http://localhost/xampp/appears the screen where you should choose your language. When I choose the language, the problem appears and I am getting this message:

Warning: file_put_contents(../../install/xampp_language.txt) [function.file-put-contents]: failed to open stream: No such file or directory in D:\xampp\htdocs\xampp\lang.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at D:\xampp\htdocs\xampp\lang.php:2) in D:\xampp\htdocs\xampp\lang.php on line 10

I installed xammp in D directory (not in C). I think that because this I have this problem. Am I right?

I readed previous post but I still can`t fix my problem. I tryed to rename xampp folder but nothing happens. I also tryed to delete it along with the 2 associated index files.

Any suggestions, please?
Thanks.
peter10
 
Posts: 1
Joined: 07. April 2014 17:44
Operating System: windows xp

Re: Error after changing htdocs settings in httpd.conf

Postby Alex R4 » 09. April 2014 03:30

Warning: Cannot modify header information - headers already sent by (output started at D:\xampp\htdocs\xampp\lang.php:2) in D:\xampp\htdocs\xampp\lang.php on line 10

The problem may be at D:\xampp\htdocs\xampp\lang.php:2
The starting tag <?php may have spaces in front of it. php does not like leading spaces in front of the opening tag. If that is the case the above warning message will be issued and the logic fails.
Alex R4
 
Posts: 31
Joined: 08. April 2014 11:24
Location: Adelaide/Australia
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests

cron