Mapping my sub domain to my server (port 6060)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mapping my sub domain to my server (port 6060)

Postby AnjinG » 12. April 2010 03:41

Hi Guys,
I'm facing a configuration headache here and i hope somebody can push me along the right direction.

I have a web server that originally hosts websites on Microsoft IIS 6.0; but i need to configure it to support Apache on it. I went ahead to install XAMPP and managed to get a php site up by configuring Apache to listen to port 6060. I am able to access the site via <server name>:6060 through my local network.

Here's my problem: I have to proceed to map two websites hosted in XAMPP to 2 sub-domains that my system administrator has set up via his domain provider. The sub-domains are pointing to my server's IP address, which I understand that by default it will lead into my IIS instead of my Apache server as it will be coming in via port 80 (please correct me if i'm wrong). I also understand from my system admin that he is not able to include a port number on the domain provider.

Can somebody assist in directing me on how can i map the domain name to my website in Apache?

Just for the record i'm using XAMPP v1.6.7 on Windows Server 2003

Thanks in advance,
AnjinG
 
Posts: 3
Joined: 12. April 2010 02:53

Re: Mapping my sub domain to my server (port 6060)

Postby Narrowboyy » 12. April 2010 04:40

The easiest and less complex way is to:
1. Disable completely IIS using the Windows Control Panel>Add Remove Programs>Add Remove Windows Components.
or
2. Have IIS listen on another port (link)

3. Revert the Listen directive to port 80 in Apache.

This should now have you using once again port 80 and then you won't have any issues with your mapping.

If you run Apache using XAMPP then IMHO there is no need for an inferior and security riddled server like IIS.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Mapping my sub domain to my server (port 6060)

Postby AnjinG » 12. April 2010 05:07

Narrowboyy wrote:The easiest and less complex way is to:
1. Disable completely IIS using the Windows Control Panel>Add Remove Programs>Add Remove Windows Components.
or
2. Have IIS listen on another port (link)

3. Revert the Listen directive to port 80 in Apache.

This should now have you using once again port 80 and then you won't have any issues with your mapping.


Hi Narrowboy,
I wish i could just remove IIS, but i have other sites configured for IIS since they are developed using .Net. So regretfully i can't do that.
The websites on IIS number around 10 compared to 2 on the apache; i would rather configure the apache if possible, rather then bring 10 sites down if i accidentally do something.
AnjinG
 
Posts: 3
Joined: 12. April 2010 02:53

Re: Mapping my sub domain to my server (port 6060)

Postby Narrowboyy » 12. April 2010 05:29

Can you explain then why you want to run an Apache web server when you are happy and familiar with IIS?

If IIS is Listening on port 80 then Apache can't Listen for request coming in on port 80 as well.

If you want to have a php web site then you can use IIS for this also, you don't have to have an Apache server to run PHP.
This web search may have more on IIS and PHP (link)
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Mapping my sub domain to my server (port 6060)

Postby AnjinG » 14. April 2010 03:04

hmm that is a question that i find difficult to answer; one of those 'follow instructions and try to do it' kind of assignments
anyways i'll see if i can do a redirect from the IIS then; many thanks for the help :D
AnjinG
 
Posts: 3
Joined: 12. April 2010 02:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests