New install - locating webs

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New install - locating webs

Postby gandalf458 » 08. April 2010 15:15

I have successfully installed XAMPP on a new Win 7 machine. I have my webs in c:\xampp\htdocs\www\ as on my old PC however I can't remember what changes to make to have http://localhost/www/ point to c:\xampp\htdocs\www\
Can anyone help please? Thanks
Blessed are the cracked for they let in the light
gandalf458
 
Posts: 11
Joined: 01. April 2008 19:41

Re: New install - locating webs

Postby Altrea » 08. April 2010 20:09

localhost points on default to your htdocs folder, so every subfolder in your htdocs is already a subfolder in your URL.
No changes needed.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8287
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: New install - locating webs

Postby gandalf458 » 08. April 2010 20:16

Thanks. Something is wrong though since if I point my browser to http://localhost/www/ I get a 404 error...
Blessed are the cracked for they let in the light
gandalf458
 
Posts: 11
Joined: 01. April 2008 19:41

Re: New install - locating webs

Postby Narrowboyy » 09. April 2010 01:03

gandalf458 wrote:Thanks. Something is wrong though since if I point my browser to http://localhost/www/ I get a 404 error...
When ever you get an Apache server error message in your browser, first check the \xampp\apache\logs\error.log file for clues.

If you still have the index.php and index.html in the htdocs folder then either rename them or delete them - you can still access the XAMPP demo pages by http://localhost/xampp/index.php
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: New install - locating webs

Postby gandalf458 » 09. April 2010 14:57

Stranger and stranger. I don't seem to have an xampp\apache\logs folder and other than my www folder there is nothing in the htdocs folder - unless they are hidden (I'm still getting used to Win 7).

However, everything seems to be working http://localhost/ takes me to /http://localhost/xampp/ and everything there seems to be working, including phpMyAdmin.
Blessed are the cracked for they let in the light
gandalf458
 
Posts: 11
Joined: 01. April 2008 19:41

Re: New install - locating webs

Postby gandalf458 » 09. April 2010 19:32

Okay it was a bum install - I've uninstalled and re-installed it and hey-presto, my webs are there.

Thanks
Blessed are the cracked for they let in the light
gandalf458
 
Posts: 11
Joined: 01. April 2008 19:41


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests