XAMPP Apache Not Starting...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Apache Not Starting...

Postby chadderbox25 » 07. April 2010 21:27

XAMPP Apache is not starting.

This is what happens when I run xampp-portcheck.exe:
(I have MySQL and FileZilla both running in XAMPP)
Image

What is wrong?
chadderbox25
 
Posts: 2
Joined: 07. April 2010 18:59

Re: XAMPP Apache Not Starting...

Postby kenneths » 08. April 2010 00:32

Do you by any chance have skype installed? :)
If so check the settings, there is a chechbox (was enabled with me) that lets skype use port 80 and another one to accept calls.
Once I disabled this it started for me.
kenneths
 
Posts: 4
Joined: 08. April 2010 00:30

Re: XAMPP Apache Not Starting...

Postby Narrowboyy » 08. April 2010 00:52

Check out the \xampp\apache\logs\error.log file.

You seem to have something running as a service hogging port 443.

See if this post helps:
viewtopic.php?f=16&t=40062&p=158918#p158918

If you can't find what is using port 443 then you can disable Apache's use of port 443 by editing the httpd.conf file and adding a # to this line so it looks like this
Code: Select all
# Secure (SSL/TLS) connections
# Include "conf/extra/httpd-ssl.conf"
or alternatively you can use another port for SSL by editing the above mentioned \xampp\apache\conf\extra\httpd-ssl.conf file and change all the references to port 443 to port 4433 for example.

If you make any changes to any conf file or ini file in XAMPP always make a backup copy of the original first, then save the file and try and start Apache again.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: XAMPP Apache Not Starting...

Postby rstorrs » 13. April 2010 04:02

Having the same problem. This is the error log

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down

??????????
rstorrs
 
Posts: 3
Joined: 12. April 2010 16:48

Re: XAMPP Apache Not Starting...

Postby rstorrs » 26. April 2010 00:34

Thanks narrowboyy your post reference mentioned changing the httpd.config file "Listen 80" to Listen 85".

I made this change and Apache will at least start.

Bob
rstorrs
 
Posts: 3
Joined: 12. April 2010 16:48

Re: XAMPP Apache Not Starting...

Postby MC10 » 26. April 2010 01:33

rstorrs wrote:Having the same problem. This is the error log

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down

??????????


Something is running on port 80. Can you run a port check on port 80?
MC10
 
Posts: 148
Joined: 20. February 2010 20:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests