Apache not running

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Apache not running

Postby stardog » 14. June 2010 15:15

JonB wrote:Take a look at this, it may provide your answer.

viewtopic.php?f=16&t=40717&p=161042#p161042

Good Luck
:)


I had already uninstalled the official version of Apache before installing XAMPP, but the problem still persists. I also stopped Skype from trying to use port 80. Like I said before, Apache worked the first time I installed it, but not after that. Also, the port checker that comes with XAMPP tells me that port 80 is free, yet Apache can't bind to it. mySQL and everything else work just fine--just not Apache.
stardog
 
Posts: 5
Joined: 14. June 2010 01:10
Location: Ibaraki, Japan

Re: Apache not running

Postby Radzio » 14. June 2010 15:57

Run as administrator:
Code: Select all
netstat -an | find ":80"

And post the results.
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26

Re: Apache not running

Postby Altrea » 14. June 2010 15:58

Please check port 443, too.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache not running

Postby Radzio » 14. June 2010 16:04

Altrea wrote:Please check port 443, too.

Apache doesn't complain about it but right, it's a good idea to check it as well.
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26

Re: Apache not running

Postby stardog » 14. June 2010 16:15

OK, here goes:

Microsoft(R) Windows DOS
(C)Copyright Microsoft Corp 1990-2001.

C:\DOCUME~1\ADMINI~1>netstat -an | find ":80"
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 192.168.3.8:3023 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3024 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3025 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3026 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3027 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3028 66.111.102.110:80 TIME_WAIT
TCP 192.168.3.8:3029 69.192.252.20:80 TIME_WAIT
TCP 192.168.3.8:3033 66.249.89.155:80 TIME_WAIT
TCP 192.168.3.8:3034 66.249.89.148:80 TIME_WAIT
TCP 192.168.3.8:3036 64.233.183.167:80 TIME_WAIT
TCP 192.168.3.8:3037 64.233.183.167:80 TIME_WAIT
TCP 192.168.3.8:3040 60.254.154.91:80 TIME_WAIT
TCP 192.168.3.8:3056 66.249.89.155:80 TIME_WAIT
TCP 192.168.3.8:3063 66.249.89.155:80 TIME_WAIT
TCP 192.168.3.8:3065 208.122.62.226:80 TIME_WAIT
TCP 192.168.3.8:3066 208.122.62.226:80 TIME_WAIT
TCP 192.168.3.8:3067 63.215.202.6:80 TIME_WAIT
TCP 192.168.3.8:3071 60.254.154.105:80 TIME_WAIT
TCP 192.168.3.8:3072 207.171.166.37:80 TIME_WAIT
TCP 192.168.3.8:3073 69.5.9.11:80 TIME_WAIT
TCP 192.168.3.8:3080 60.254.154.99:80 TIME_WAIT
TCP 192.168.3.8:3083 60.254.154.120:80 TIME_WAIT
TCP 192.168.3.8:3084 60.254.154.120:80 TIME_WAIT
TCP 192.168.3.8:3085 60.254.154.120:80 TIME_WAIT
TCP 192.168.3.8:3086 60.254.154.120:80 TIME_WAIT
TCP 192.168.3.8:3087 60.254.154.120:80 TIME_WAIT
TCP 192.168.3.8:3094 124.40.51.17:80 TIME_WAIT
TCP 192.168.3.8:3142 98.138.82.25:80 ESTABLISHED
TCP 192.168.3.8:3146 69.63.180.46:80 ESTABLISHED
TCP 192.168.3.8:3148 66.220.146.25:80 ESTABLISHED

C:\DOCUME~1\ADMINI~1>netstat -an | find ":443"
TCP 192.168.3.8:3143 74.125.153.18:443 ESTABLISHED
TCP 192.168.3.8:3145 72.14.203.17:443 ESTABLISHED
TCP 192.168.3.8:3147 64.233.183.189:443 TIME_WAIT
stardog
 
Posts: 5
Joined: 14. June 2010 01:10
Location: Ibaraki, Japan

Re: Apache not running

Postby Radzio » 14. June 2010 16:19

There is something listening on 0.0.0.0:80 let's find out what it is!
Run (as admin):
Code: Select all
netstat -abn

And manually find the record for 0.0.0.0:80 (should be at the top). EXE's name is just below it.
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26

Re: Apache not running

Postby stardog » 14. June 2010 23:21

OK, this is officially getting bizarre. I ran netstat like you said, and nothing came up as listening on port 80.
stardog
 
Posts: 5
Joined: 14. June 2010 01:10
Location: Ibaraki, Japan

Re: Apache not running

Postby JonB » 14. June 2010 23:59

try activeports (free) to monitor ports.

http://www.devicelock.com/freeware.html

for netstat to catch it, it would have to be active (I'm pretty sure) when netstat was running.

There is also the small possibility you have some variant of a rootkit.

I'm hoping we will all wind up saysing "OH that's what that was" because we missed something obvious -

One question - is http.sys present and started in Services Control Management? (you can access it with the SCM option in XAMPP Control Panel -- or though Computer Management, Services) If so, that is the culprit - chnage its startup type to manual.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache not running

Postby stardog » 15. June 2010 06:05

*facepalm* OK, I know what it was. I'm also using VMWare, and it was listening on port 80. I've disabled it for now, since I'm going to be testing stuff using localhost for the time being.

Anyway, huge shoutout to Jon B. and everyone else for all your help. Much appreciated.

Stardog.
stardog
 
Posts: 5
Joined: 14. June 2010 01:10
Location: Ibaraki, Japan

Re: Apache not running

Postby borgen44 » 15. June 2010 11:13

Hey,,

I have tryed to follow some of the guides in this fora, but nothing seems to work.

Here is a output from my error.log file, but i dont know what it says:

Code: Select all
[Mon Jun 14 18:58:34 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 14 18:58:34 2010] [notice] Digest: done
[Mon Jun 14 18:58:34 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jun 14 18:58:34 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jun 14 18:58:34 2010] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Mon Jun 14 18:58:34 2010] [crit] master_main: create child process failed. Exiting.
[Mon Jun 14 18:58:34 2010] [notice] Parent: Forcing termination of child process 36
[Mon Jun 14 18:58:45 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 14 18:58:45 2010] [notice] Digest: done
[Mon Jun 14 18:58:46 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jun 14 18:58:46 2010] [notice] Server built: Nov 11 2009 14:29:03
[Mon Jun 14 18:58:46 2010] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Mon Jun 14 18:58:46 2010] [crit] master_main: create child process failed. Exiting.
[Mon Jun 14 18:58:46 2010] [notice] Parent: Forcing termination of child process 36
[Tue Jun 15 12:07:29 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Jun 15 12:07:29 2010] [notice] Digest: done
[Tue Jun 15 12:07:30 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Jun 15 12:07:30 2010] [notice] Server built: Nov 11 2009 14:29:03
[Tue Jun 15 12:07:30 2010] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Tue Jun 15 12:07:30 2010] [crit] master_main: create child process failed. Exiting.
[Tue Jun 15 12:07:30 2010] [notice] Parent: Forcing termination of child process 36


Any clues on what to do?
borgen44
 
Posts: 2
Joined: 15. June 2010 11:09

Re: Apache not running

Postby Radzio » 15. June 2010 11:27

Some security software may block Apache. Try uninstalling/disabling firewalls, AVs, ISs and whatever else you have there.
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26

Re: Apache not running

Postby borgen44 » 15. June 2010 11:53

I have Avira and Microsoft Security Essentials,,

But i cant find anything blocked.
borgen44
 
Posts: 2
Joined: 15. June 2010 11:09

Re: Apache not running

Postby Radzio » 15. June 2010 11:57

You have 2 AVs?!
You may also have a working firewall or even more than one!
Are you sure you know what you are doing?
Apache cannot start because some app prevents it from creating another process.
This is done by some behavioural-based av engines.
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26

Re: Apache not running

Postby nuiken » 17. June 2010 23:13

anirbang11 wrote:Hi everybody,
This is my first post in this forum and I am sure I will get the answer. Thanks in advance.

I installed Xampp 1.7.2 for windows in my machine. And the Installation process was done without error or warning.
But when I want to run apache from control panel, it is not running, no error message is giving.
But Mysql and others are running well.

please give me a solution how to overcome this problem.



I'm a newbie here but what I've done to solve this problem on my end was the following:
1. Go to the apache folder
2. Run the apache_uninstallservice batch file
3. Run the apache_installservice batch file
4. Smile bc all was all was happy with the world since http:/localhost started working like it should :-)
Hope this helps 'cause boy was I getting frustrated.
nuiken
 
Posts: 1
Joined: 17. June 2010 23:04

Re: Apache not running

Postby Badman3k » 22. June 2010 17:34

Hey,

I've tried all of the solutions given in the post thus far, and I've searched the forums for other similar posts - nothing seems to work with my system.

I've looked at the error logs and this is what I get:
Code: Select all
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

I run a port check and it tells me "Process: System" is using port 80. This is further confirmed using the netstat command, which indicates PID 4 which is System.

I'm running Windows 7 Ultimate x64. I've had XAMPP running since I installed Windows 7 and I can't seem to find what part of the system is currently bound to port 80.

To confirm: Skype is not using port 80. IIS is not installed as far as I can tell. VMWare is disabled and not running.

EDIT: Immediately after posting this, I found the culprit. I had recently installed MS SQL Server 2008 Express. As part of this there is a service called: SQL Server Reporting Services. Make sure that all the wonderful new services that MS SQL Server 2008 use are manual starts... or don't bother installing it to start with.

Many thanks in advance,
Richard.
Badman3k
 
Posts: 1
Joined: 18. October 2004 18:34

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests