Cyrilic doesn't show up!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cyrilic doesn't show up!

Postby petbat » 03. April 2010 21:07

Well... I'm trying to make a website with cyrilic but it shows only weird symbols xD
Will someone help me?!
Thanks in advance

-- petbat
petbat
 
Posts: 5
Joined: 03. April 2010 17:53

Re: Cyrilic doesn't show up!

Postby Altrea » 03. April 2010 23:36

petbat wrote:Will someone help me?!


Without any information about what you have already done?
no chance!
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Cyrilic doesn't show up!

Postby kenneths » 08. April 2010 00:40

this is just a guess, but you may have to specify charset. UTF-8 I think :)
kenneths
 
Posts: 4
Joined: 08. April 2010 00:30

Re: Cyrilic doesn't show up!

Postby petbat » 08. April 2010 09:20

Will you show me how to do it? Please... and I need to add it to a '.php' file and I don't know if it will work, because it's a big "ocean" there hehe :D
there are ~5000+ files at the website folder and I don't know will this work :)
Thanks in advance!

-- petbat
petbat
 
Posts: 5
Joined: 03. April 2010 17:53

Re: Cyrilic doesn't show up!

Postby kenneths » 08. April 2010 12:18

http://www.w3.org/International/tutorials/language-decl/ :)

+
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
kenneths
 
Posts: 4
Joined: 08. April 2010 00:30

Re: Cyrilic doesn't show up!

Postby petbat » 08. April 2010 19:08

Thank you, but how to add it?!
I mean I've added this to the index.php :
<html>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
</html>

But now everything on the site is bold and I still can't see cyrillic letters... xD
petbat
 
Posts: 5
Joined: 03. April 2010 17:53

Re: Cyrilic doesn't show up!

Postby Narrowboyy » 09. April 2010 00:57

Make sure that your browser has the Cyrillic language set as default language by checking the Browser's Options or Preferences for a Language setting - by default they are usually set to a language Western (ISO-8859-1) until you change it via the Language settings.
Narrowboyy
 
Posts: 64
Joined: 16. February 2009 02:56

Re: Cyrilic doesn't show up!

Postby petbat » 09. April 2010 11:26

I know about this, but when I set this option and I load the next page it's back on Western...
Also if you want to check another website, similar to mine, with is cyrillic and has no problems... http://dragonfire-bg.net
petbat
 
Posts: 5
Joined: 03. April 2010 17:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 79 guests