SSL (Really) isn't Working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

SSL (Really) isn't Working

Postby Nobody_Special » 03. April 2010 18:15

I've spend more hours than I can count on this. Read and tried every Goggle-offered solution. Obvious answer doesn't seem to exist. :shock: Any suggestions are welcome.

I have tried all sorts of ways around this, but with SSL Enabled, all I seem to get is one the following errors:
1. Server should be SSL-aware but has no certificate configure (solution: move the SSLCertificateFile line to http.conf)
2. Init: SSLPassPhraseDialog builtin is not supported on Win32 (solution: SSLPassPhraseDialog points to text file with password)
- #SSLPassPhraseDialog does not seem to fix this.
3. Init: Private key not found (solution: no clue. whatever I put in text file, same error)

More Details:

I was running WinVista, xAmpp v1.7.1 and everything worked just fine.

I upgraded to Win7, xAmpp v1.7.3 and a bunch of things for oscommerce became broken because of the updated PHP v5.32. After searching I fixed the OSCommerce problems, and now down to an incredibly irritating SSL issue. (Works fine with SSL Disabled)

Created a Key and a CSR. I removed the passphrase from the key with openssl. Received my new CRT from GoDaddy. Linked them into xAmpp 1.7.1 and everything was fine.

After the upgrade:
1. it kept asking for the SSLCertificateFile, as it did not seem to be seeing it in the httpd-ssl.conf so I needed to move the SSLCertificateFile conf/ssl.crt/ line into the http.conf before it would recognize it.
2. then, it kept asking for the PassPhrase, that I already removed from the Key.
3. I used a SSLPassPhraseDialog exec:path/to/filename only to be told Init: Private key not found

Even though it all worked fine in v1.7.1 1st try, I started over.
1. Created the Key, removed the passphrase, THEN created the CSR and got the CRT.
2. All the same exact problems
Posts: 2
Joined: 03. April 2010 17:46

Re: SSL (Really) isn't Working

Postby Nobody_Special » 04. April 2010 00:17

I reinstalled, went step by step, and I narrowed it down to this problem:

When I add the following lines to my Virtual Host section, at the very bottom of http.conf:
<VirtualHost *:443>
ServerAlias *
DocumentRoot /Servers/WebSites/website

I get the following error (even though it is in the http-ssl.conf file):
[error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)

Without that VirtualHost part above, it defaults to the xAmpp folder, with an Access Forbidden message. Somewhere, in one of these documents, is something telling the server to deny the use of Port 443 for SSL. This is currently in the most bare minimum install I could possibly do. I put in the GoDaddy CRT and the KEY, add the VirtualHost *:443 and bam, it stops working.
Posts: 2
Joined: 03. April 2010 17:46

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests