Localhost works but 168.192.1.4 doesn't?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost works but 168.192.1.4 doesn't?

Postby Steve22 » 21. March 2010 19:09

This is my 1st time using XAMPP so i'm not all that familiaar with it. Usually when things go wrong I mess around until I do even more damage but this time I'm just going to ask for help right out.

A couple of days ago I installed XAMPP 1.7.3 in a C:\\ SERVER directory. I'm using it to work on a Joomla web site. While I've dealt with Joomla quite a bit before I've never tried it on localhost.
After the initial install everything worked great. I Installed the web site, and even worked on it for 2 days. I could view my site from http://localhost and from http://192.168.1.4. no problems. I event port forwarded my router to be able to have people test the site with a free .tk domain. Even that was working flawlessly.

The problems started after I restarted my PC. Now http://localhost still works but both my internal and external IP addresses DO NOT. Firewalls are disabled of course.
In Xampp control panel my Apache and SQL show both as running and the text dialog below tells me everything is ok.
But when I go to the "status" link on the xampp page in http://localhost/xampp/ it says a lot of things don't work.

MySQL database DEACTIVATED
PHP DEACTIVATED
Perl with mod_perl DEACTIVATED
Apache::ASP DEACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) DEACTIVATED
Server Side Includes (SSI) DEACTIVATED
IPv4 DEACTIVATED
IPv6 ACTIVATED
SMTP Service ACTIVATED
FTP Service DEACTIVATED

When i 1st installed it before the computer reboot most of them worked except 2 which i think were
Server Side Includes (SSI) and SMTP Service.
I've tried restarting the PC again - no luck.
I've uninstalled and reinstalled apache and mysql from the XAMPP control panel - no fix

Finally I noticed something : If i run the xampp_restart.exe from the C:\SERVER\xampp folder I get this error.

Can't find process C\:SERVER\xampp\apache\bin\httpb.exe
Can't find process #6088

Any idea or insight on how I should go about fixing this? I read a somewhat similar post where it was suggested to search for a missing file and put it manually in the directory but the said file already exict in the said directory. Plus it said "process" missing not file. I have no idea what to do next. Any help would be much appreciated. I'm on windows Vista 32 bit.
Steve22
 
Posts: 1
Joined: 21. March 2010 18:45

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests