Apache starts, then stops: Not running IIS or Skype ...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache starts, then stops: Not running IIS or Skype ...

Postby timcaviness » 17. March 2010 02:46

I've researched this for hours and read many posts about happy people who killed Skype or unchecked the option for port 80 and 443 in Tools>Admin ... and I'm happy for them.

But I still can't get this &*^%*&^% thing to work after I've had it working just fine.

I look in my httpd logs and find that the last time I used it was Feb 13, about a month ago. I installed Windows 7 sometime in lat 2009 so I know XAMPP has worked on this machine with its current OS.

I'm running Xampp 1.6.8 on Windows 7 Ultimate. Skype is not loaded and IIS has never been installed on this machine. (I run this exact XAMPP on my machine at work where I have Skype and do not have problems - I don't have it loaded when I run XAMPP)

I run apache_start.bat from the cmd line and here's what I get:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .


I changed my http.conf from "Listen 80" to "Listen 127.0.0.1:80" as I've seen suggested and voila:

C:\xampp>apache_start.bat
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : make_sock: could not bind to address 127.0.0.1:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .


The same error, different IP.

I've seen LOTS of people have this same error so there's got to be someone out there who knows what's happening.

I've run "netstat -ano" to find that the process "SYSTEM" has port 80.

I've run "xampp-portcheck" to find out the same thing, port 80 has a status of "SYSTEM."

I've rebooted to no avail.

I've even run XAMPP "as an administrator" and it's still a no-go.

Is there a way to find out exactly what system process (PID=4) has hold of port 80? What am I missing? Is there an easy way to tell what programs were installed since Feb 13 so maybe I can find the culprit that way?

I'm stumped and for once, Googling the problem hasn't found me a solution.

Thanks in advance,
Tim
timcaviness
 
Posts: 3
Joined: 17. March 2010 02:19

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby timcaviness » 17. March 2010 02:56

Here are the programs installed since I last had XAMPP working ... are any of these known conflicts like Skype and IIS?

Nero 9
SoundForge Pro 10
Noise Reduction Plug-in 2.0i
Microsoft Visual C++ 2008 Redistributable - x86
Hercules Classic Silver (webcam driver)
Java 6 Update 18
Adobe Flash Player 10 Activex
Adobe Flash Player 10 Plugin
TurboTax 2009

-Tim
timcaviness
 
Posts: 3
Joined: 17. March 2010 02:19

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby MC10 » 17. March 2010 03:54

From the "netstat -ano" command, you should have received a PID (Port ID). Open up the Windows Task Manager and search up the PID. (This may be of some help to you.)
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby timcaviness » 17. March 2010 04:01

yes, it was (PID=4), which is "SYSTEM" ... that was buried somewhere in my first post ..

sorry, I wanted to post all the info I had because I have literally been banging my head on this all night ..

Tim
timcaviness
 
Posts: 3
Joined: 17. March 2010 02:19

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby jimmmy » 26. March 2010 03:29

hey tim. i was having the same problem, looking for hours for a solution when I found this over in another part of the forum. Thought I'd share:


Re: XAMMP-- Apache not running, port 80 already in use.

Postby mkdowning » 26. February 2010 06:07
It just says "System". But, I did manage to fix this, and since this is a common problem, I will share. Port 80 on windows 7 is occupied by a program called "World Wide Web Publishing Service". Not sure what it does, don't really care either, I've had it turned off for awhile now and nothing dire has happened. So, to turn this off, right click on "computer", click on "manage", click on "service & applications", then click on "services", and then scroll down to "world wide web publishing service". Right click on it, and tell it to "stop"! This fixed my problem INSTANTLY!!


Not really sure what stopping world wide web publishing service means either, but Apache worked.

Jimmy
jimmmy
 
Posts: 4
Joined: 26. March 2010 03:10

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby MC10 » 27. March 2010 05:10

That's IIS, but I doubt that IIS would be labeled as "SYSTEM".
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby MC10 » 27. March 2010 05:20

Could you try "nmap localhost"?
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby webmobo » 10. November 2011 22:41

Hi Guys, I know this an old topic, but thought i'd share my similar experience too!

My Apache would run and then turn off (within a few seconds) - turned out to be a listening vpn connection i had recently created causing the problem, as soon as i disabled the incoming connection it worked!
webmobo
 
Posts: 1
Joined: 10. November 2011 22:34
Operating System: Win7

Re: Apache starts, then stops: Not running IIS or Skype ...

Postby allanice001 » 30. May 2012 20:14

i just found that teamviewer also uses port 80 & 443.
if you're using teamviewer:
Extras -> Options
Advanced => Show advanced options
Close to the bottom tick the box that says "Don't use incoming ports 80 and 443 (recommended for webservers only_

Ok

And Voilla, apache functions again
allanice001
 
Posts: 1
Joined: 30. May 2012 20:08
Operating System: Win 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests