MySQL service does not Start - XP Pro

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL service does not Start - XP Pro

Postby Steven Avery » 12. March 2010 09:41

Hi Folks,

First .. if I decide to have XAMPP and WAMP installed, and then turn on one services at a time by hand (for now) is there any potential clash of significance ? I am thinking of doing that to see if MYSQL loads properly under WAMP.

============================

CONFIGURATION

xampp installed at xp-pro in d:\xampp
Apache server starts fine

PROBLEM

http://localhost/xampp/
"Status -
MySQL database decactivated"

And then I try to start MySQL from Xampp control panel

"Busy
MySQL Service started"

(but it does not start)

Try Browser :
http://localhost/phpmyadmin/
"Welcome to phpMyAdmin
Error
MySQL said:
#2003 - Can't connect to MySQL server on 'localhost' (10061)
Connection for controluser as defined in your configuration failed."

services.msc
"Could not start the MySQL service on Local Computer.
Error 1067: The process terminated unexpectedly."

mysql.err
100304 20:41:02 [Note] Plugin 'FEDERATED' is disabled.
100304 20:41:04 InnoDB: Started; log sequence number 0 46409
100304 20:41:06 [Note] Event Scheduler: Loaded 0 events
100304 20:41:06 [Note] D:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.1.41' socket: '' port: 3306 Source distribution

Only shows this once though.

Run Currports from Xampp control panel
(Port-check)
Shows port 3306 open
Mysql 3306 free

Windows Firewall off
Firewall Online armor paid shows no problem, and same message when Firewall temporarily deactivated.

=============================

LOOK FOR SOLUTIONS ON NET

One answer about "controluser" message was:

this is only a phpmyadmin warning message.
you have to update the password from pma user with the new
config.inc.php:$cfg['Servers'][$i]['controlpass']

My config.inc.php file (untouched, unmodified) has

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

It is hard for me to know if that is applicable, I have a pure, unmodified Xampp install so should not have to mess with passwords, yet.

========================================

Other suggestions here and there:

Clear Firefox Browser Cache (done)
Remove, deactivate IIS
"I've resolved this by removing the my.ini file from the windows directory! "

========================================

Am I missing something very basic ?
Your suggestions ?

Thanks for any assistance.

Shalom,
Steven Avery
Steven Avery
 
Posts: 2
Joined: 07. March 2010 12:20

Re: MySQL service does not Start - XP Pro

Postby MC10 » 12. March 2010 20:50

I think you may have set a password to your "root" and "pma" accounts. In your config.inc.php, add the passwords for the lines you listed.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: MySQL service does not Start - XP Pro

Postby Steven Avery » 13. March 2010 23:56

Hi Folks,

MC10 wrote:I think you may have set a password to your "root" and "pma" accounts. In your config.inc.php, add the passwords for the lines you listed.

Thanks, MC10. That would likely only be if I was prompted for a password on install, since I did not not initiate any password activity.

So I tried what password I would have put in .. putting it into the config.inc.php in both places. After that I worked with the idea of starting with an init file that passes the password, that I know matches. A bit unwieldy.

I did get an interesting message when I tried to turn on MySQL by hand.

C:\>D:\xampp\mysql\bin\mysqld.exe --init-file=D:\aapassword.txt
100312 20:12:52 [Warning] Can't create test file \usr\local\mysql\data\dell-precision.lower-test
100312 20:12:52 [Warning] Can't create test file \usr\local\mysql\data\dell-precision.lower-test
D:\xampp\mysql\bin\mysqld.exe: Can't change dir to '\usr\local\\mysql\data\' (Errcode: 2)
100312 20:12:52 [ERROR] Aborting
100312 20:12:52 [Note] D:\xampp\mysql\bin\mysqld.exe: Shutdown complete

Maybe that has to do with permissions or something ? Should I try logging on as administrator ? However, I want the root of the problem.

For now (after a little wait to see if there is some good feedback) I am going to turn off the Apache services, install WAMP and see if I have any similar problem. If I do, then back to the drawing board. I'll report back, I am looking forward to some development and web stuff that includes MYSQL and want the home base to work with.

Shalom,
Steven Avery
Steven Avery
 
Posts: 2
Joined: 07. March 2010 12:20

Re: MySQL service does not Start - XP Pro

Postby Fimake » 25. March 2010 19:41

Steven Avery wrote:Hi Folks,
http://localhost/phpmyadmin/
"Welcome to phpMyAdmin
Error
MySQL said:
#2003 - Can't connect to MySQL server on 'localhost' (10061)
Connection for controluser as defined in your configuration failed."


I have spent something like 5 hours with this same 10061 error message and Google, with no working tips. I have even done three times totall re-installs from nil. Yet this error did not go away. Xampp documentation says that it does not write to Windows registry, but I believe its does. At least if you try for a couple of months to use and test all the Xampp features that there are available. I don't know another place than Registry where those erroneous settings could reside.

The solution that worked for me was very simple, once I found it after those hours. Usually, when Xampp Control Panel opens without any errors, there is Setup button visible on the right hand of Control panel. But when I had this error on, the button did not show itself at all.

Once the button is visible you can click it you get this menu:
Code: Select all
  1. start XAMPP Control Panel
  2. relocate XAMPP
     (current path: H:\xampp)
  3. disable HTTPS (SSL)
...


If you do get that menu, and run "relocate XAMPP", then Xampp starts a huge PHP script that updates total 74 files in several subfolders. It writes in to all these files the currrent Xampp install path like "H:\XAMPP". Within these 74 files there are several Windows registry files with .REG extension. Even though the routine does not Import those registry files at the same time, I believe this is the route how some setting could get in to Windows registry. And these may afterwards cause this 10061 havoc.

But hey, the Start button does not appear in Xampp control Panel if there are some conflicts with PHP and MySql or something. Fortunately there is standard setup_xampp.bat file on the background doing the launch job. Even this BAT file itself is quite huge 490 lines, and it calls PHP script that actually does the job for those 74 files.

My 10061 problem went away, once I ran that setup_xampp.bat and 2. choice through.

But there may be cases when you can't even get that setup_xampp.bat started. I was not able to reproduce what exactly was the situation why it did not run at all. When this batch error situation was on, I could not get Apache to get started. When I tried to start Apache, the Apache "Running" text appeared for about 3 seconds, and then went away.

It may be that the PHP interpreter is for some reason not able to start, and that prevents BAT file from doing anything.

So this tip probably is not able to solve all 10061 problems. Yet I decided to share my findings. Maybe this will help someone else some day;)
F.
Fimake
 
Posts: 1
Joined: 25. March 2010 18:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests