Authentication required

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Authentication required

Postby addACUMEN » 10. March 2010 14:13

I have changed my XAMPP installation. I uninstalled previous versions of XAMPP using the Uninstall. I then loaded the executable and ran it. All the reports seem normal.

On a Windows Vista Ultimate machine I installed it to C:/ (sorry, keyboard doesn't have the other kind of slash). It appears exactly as I would expect. It is a standalone machine connected wirelessly to the internet and running F-Secure security with permissions set for Apache and MySQL.

Using Firefox, Chrome or IE for 127.0.0.1 with or without http:// or localhost produce a request for a username and password.

The XAMPP control panel shows that both Apache and MySQL are running - green light indicators.

Port check shows http, https and MySQL all as system and everything else as free.

Looking at the error log there are lines as shown below.

[Wed Mar 10 13:49:09 2010] [error] [client 127.0.0.1] at the beginning of each line but here is the important content.

(OS 3)The system cannot find the path specified. : Could not open password file: C:/xampp/xampp/security/xampp.users
File does not exist: C:/xampp/htdocs/favicon.ico
(OS 3)The system cannot find the path specified. : Could not open password file: C:/xampp/xampp/security/xampp.users
File does not exist: C:/xampp/htdocs/favicon.ico
File does not exist: C:/xampp/htdocs/favicon.ico

It is correct that the favicon file does not exist.
It is also correct that the directory /xampp/xampp/security/ does not exist - I think it should be referring to /xampp/security/ The named directory did exist in one of the uninstalled implementations of an earlier version of XAMPP. Where does Apache find this directory address?

Can you please advise me how to untangle this?
Is the correct syntax for the xampp.users file as shown below?

username = "username"
password = "password"
Thank you for your help

Tony D
addACUMEN
 
Posts: 15
Joined: 02. March 2007 22:26
Location: Wengen, Switzerland

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests