Upgrade php 5.3.1 to 5.3.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Upgrade php 5.3.1 to 5.3.2

Postby mrbinky3000 » 21. April 2010 20:50

I followed all the instructions and it seems to work. However, am I supposed to be seeing all these pop-up error messages each time I start Apache? Also, the original PHP files that came with Xampp are digitally signed by a Carsten Wiedmann. Where the new files downloaded directly from PHP.net are not signed. Could that be the reason why Xampp is having problems?

Posts: 1
Joined: 21. April 2010 20:19

Re: Upgrade php 5.3.1 to 5.3.2

Postby MC10 » 26. April 2010 02:50

Just comment the lines that cause the problems. For example, comment out php_pdo.dll as so:

Code: Select all
Posts: 148
Joined: 20. February 2010 20:13

Re: Upgrade php 5.3.1 to 5.3.2

Postby mahoor13 » 20. June 2010 10:53

I've want to upgrade php 5.3.1 vc6 to php 5.3.2 vc9 ts on windows 2008 32bit.
I've installed Microsoft 2008 C++ Runtime (x86) http://www.microsoft.com/downloads/details.aspx?FamilyID=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF
I've copied new php http://windows.php.net/downloads/releases/php-5.3.2-Win32-VC9-x86.zip in /xampp/php-5.3.2 directory and copy php.ini from old directory (/xampp/php) to /xampp/php-5.3.2 and replace /xampp/php with /xampp/php-5.3.2 and save new php.ini
I've changed /xampp/apache/conf/extra/httpd-xampp.conf and replace all /xampp/php with /xampp/php-5.3.2 and save the file as httpd-xampp-5.3.2.conf
then I've changed /xampp/apache/conf/httpd.conf line 460 to this:
Code: Select all
#Include "conf/extra/httpd-xampp.conf"
Include "conf/extra/httpd-xampp-5.3.2.conf"

old httpd-xampp.conf remarked and the second line is added
then restart the apache
WOW Now i have php 5.3.2 vc9 ts on phpinfo() page
:( but when i want to test mysql or mysqli connection it can not connect and wait until the timeout error acquires.
I've disabled my eset smart security 4 business edition firewall and anti virus but it still dose not work.
Posts: 1
Joined: 20. June 2010 10:27

Re: Upgrade php 5.3.1 to 5.3.2

Postby JonB » 22. June 2010 00:51

A bit after the fact, but for explanations sake:

The VC9 compiles don't work with Apache.org Windows binaries, period.


Glad you got it worked out.

User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests