PHP not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP not working

Postby Mushroom-Cookie » 05. March 2010 14:22

Hi

I'm new to PHP and I'm having some trouble getting it to work.

I've written some simple PHP code and when I open it in the internet all I get is a blank page.

The URl I'm using is http://localhost/hello.php

PHP files with just html written in them will show but PHP turns it blank.

Any help would be greatly appreciated!

Thanks so much.
Mushroom-Cookie
 
Posts: 1
Joined: 05. March 2010 14:17

Re: PHP not working

Postby Altrea » 05. March 2010 15:45

Which XAMPP Version?
Sourcecode of your simple PHP Script?

Could be a short_open_tag problem. But i can just guess without the really important informations
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: PHP not working

Postby BillClark » 06. March 2010 22:03

Hi Mushroom, and Altrea,

I am running xampp version 1.7.3 on windows vista. The index screen says its working properly! I too am getting a blank screen when I try to run my simple hello.php, I made this file with Notepad ++ and checked the properties, it is saved as a php file. If either of you have a solution I would appreciate it. Thanks in advance BillClark
BillClark
 
Posts: 9
Joined: 06. March 2010 21:48

Re: PHP not working

Postby BillClark » 06. March 2010 22:14

Hi Mushroom,

I solved the problem, I am running version 1.7.3 so I had to tag my program with .php3. I hope this helps you!
To Atrea, my apologies for not getting your hint about short tag. I could have saved some typing and a red face!!!!!!!!
I hope you both have a good day!

BillClark
BillClark
 
Posts: 9
Joined: 06. March 2010 21:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests