Bring back PHP version switch feature?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Bring back PHP version switch feature?

Postby shiva7663 » 04. March 2010 19:43

I remember there used to be a feature where you could switch between PHP4 and PHP5.

I would like that feature to return so that I can easily switch between PHP5.2.x and PHP5.3.x (or any available PHP versions, but those two in particular). That would allow me to keep up with the most recent version of XAMPP for Windows but still have the option to drop back on the PHP version.

This would make a future transition to PHP6 a bit easier, too.
shiva7663
 
Posts: 3
Joined: 25. February 2009 22:07

Re: Bring back PHP version switch feature?

Postby cthackers » 05. March 2010 08:12

there is a .bat file in the root of xampp instalation folder called php-switch.bat
cthackers
 
Posts: 14
Joined: 03. March 2010 20:06

Re: Bring back PHP version switch feature?

Postby Altrea » 05. March 2010 10:14

cthackers wrote:there is a .bat file in the root of xampp instalation folder called php-switch.bat


not in the latest xampp releases
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Bring back PHP version switch feature?

Postby shiva7663 » 05. March 2010 15:41

Would it work if I plundered an outdated release for that .bat file and tried to adapt it to my needs? Not sure how big an effort that would be; it would probably result, at the very least, in "we only support current releases" replies from the Great Powers. heh.

I'd feel a lot more comfortable with the idea if it were returned as an official feature, though.
shiva7663
 
Posts: 3
Joined: 25. February 2009 22:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests