unable to open up //localhost/phpmyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

unable to open up //localhost/phpmyadmin

Postby garyww » 04. March 2010 11:42

i press start on the xampp control panel of mysql it said 'busy'
i typed //localhost/phpmyadmin
it redirected to
baidu.com

please help

I was unable to access the //localhost/phpmyadmin at the server
Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\Public\myweb\site3\catalog\includes\functions\database.php on line 16
Unable to connect to database server!
garyww
 
Posts: 35
Joined: 16. February 2009 15:38

Re: unable to open up //localhost/phpmyadmin

Postby cthackers » 04. March 2010 11:55

you might have localhost mapped to some other ip than 127.0.0.1. Look in your c:\windows\system32\etc\drivers\host file and see if everything is okay there. You should have a line with '127.0.0.1 localhost'
cthackers
 
Posts: 14
Joined: 03. March 2010 20:06

Re: unable to open up //localhost/phpmyadmin

Postby garyww » 04. March 2010 13:12

i do have iis turned on
and my host file is
# 1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
127.0.0.1 skywalk-ent.com
127.0.0.1 site1.loc
127.0.0.1 site2.loc
127.0.0.1 site3.loc
127.0.0.1 site4.loc
127.0.0.1 site5.loc
127.0.0.1 site6.loc
127.0.0.1 site7.loc
127.0.0.1 site8.loc
127.0.0.1 site9.loc
127.0.0.1 site10.loc
127.0.0.1 site11.loc
127.0.0.1 site12.loc
127.0.0.1 site13.loc
127.0.0.1 site14.loc
127.0.0.1 site15.loc
127.0.0.1 site16.loc
127.0.0.1 site17.loc
127.0.0.1 site18.loc
127.0.0.1 site19.loc
127.0.0.1 site20.loc
127.0.0.1 site21.loc
127.0.0.1 site22.loc
127.0.0.1 site23.loc
127.0.0.1 site24.loc
127.0.0.1 site25.loc
127.0.0.1 site26.loc
127.0.0.1 site27.loc
127.0.0.1 site28.loc
127.0.0.1 site29.loc
127.0.0.1 site30.loc
127.0.0.1 site31.loc
127.0.0.1 site32.loc
127.0.0.1 skywebmail.loc
127.0.0.1 site33.loc
127.0.0.1 site34.loc
127.0.0.1 site35.loc
127.0.0.1 site36.loc
127.0.0.1 site37.loc
127.0.0.1 site38.loc
127.0.0.1 site39.loc
127.0.0.1 site40.loc
127.0.0.1 site41.loc
127.0.0.1 site42.loc
127.0.0.1 thechannel.loc
127.0.0.1 site43.loc
127.0.0.1 site44.loc
127.0.0.1 site45.loc
garyww
 
Posts: 35
Joined: 16. February 2009 15:38

Re: unable to open up //localhost/phpmyadmin

Postby MC10 » 05. March 2010 07:27

Did you set up a password to the root account? If so, go to \xampp\phpMyAdmin\config.inc.php and edit these lines:

Code: Select all
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type']            = 'config';
$cfg['Servers'][$i]['user']                 = 'root';
$cfg['Servers'][$i]['password']             = 'password';
$cfg['Servers'][$i]['AllowNoPassword']      = true;


replacing "password" with your actual password.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests