Mediawiki requires 5.3.2. How do I upgrade?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mediawiki requires 5.3.2. How do I upgrade?

Postby npassoc » 03. March 2010 17:37

According to the MediaWiki website, MediaWiki requires either PHP 5.3.0 or 5.3.2 because of a bug introduced in PHP 5.3.1, distributed in the latest version of XAMPP.

I downloaded the PHP 5.3.2RC2 VC6 Threadsafe version and tried installing it over the current PHP installation, then tried just replacing just the PHP from a .zip download. Neither of these attempts has the entry points Apache needs to use PHP.

Am I downloading the proper version of PHP to upgrade XAMPP? If not, do I use a different download? How do I upgrade?

Nick P.
npassoc
 
Posts: 4
Joined: 03. March 2010 16:21

Re: Mediawiki requires 5.3.2. How do I upgrade?

Postby elk_iii » 03. March 2010 23:52

I faced the same issue. The following appeared to work.
Stop apache
Rename the default php folder Install folder c:\XAMP\php to c:\XAMP\_php to get it out of the way.
Used 5.3.2rc installer package to install PHP in the c:\XAMP\php folder telling the install program where apache was installed.
The install altered c:\XAMP\apache\http.conf file by adding a PHPINIDIR entry which is also someplace else in the included configs and which creates an error. The PHPINDIR line needs to be commented out.
The installer also added a line after the PHPINIDIR entry which apache needed so only remove the PHPINDIR line.
elk_iii
 
Posts: 2
Joined: 03. March 2010 23:44

Re: Mediawiki requires 5.3.2. How do I upgrade?

Postby npassoc » 04. March 2010 02:07

Thanks for your reply

I ended up by going back to PHP 5.3.0, by downloading XAMPP 1.7.2 which had that version. I uncompressed it somewhere else, then replaced the "php" folder in XAMPP 1.7.3. I also replaced the two PHP .dlls (under Windows) in the Apache folder.

I found this on Stackoverflow.com: http://stackoverflow.com/questions/1302 ... use-joomla
npassoc
 
Posts: 4
Joined: 03. March 2010 16:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests