localhost does not display -- Windows 7 system

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: localhost does not display -- Windows 7 system

Postby Altrea » 27. February 2010 15:52

looks like there is nothing listening on your port 80, only on port 8093.

mh....
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 27. February 2010 16:33

what does that indicate? From what I read on the web, it seems that port 80 being free for Apache is good. Does this mean the problem is elsewhere?

BTW, thanks for all your time and help so far!
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 27. February 2010 16:42

That means it is very weird, that Apache can't bind port 80 although it's free.

Try the following:
Tick the svc-checkboxes of Apache and MySQL to register the Windows Services and restart your computer.
The services should start automatically while restart.
Then try the netstat command again which i posted you.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 27. February 2010 17:07

okay, a different result:
Code: Select all
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Steve Aplin>netstat -aon | find ":80"
  TCP    0.0.0.0:8093           0.0.0.0:0              LISTENING       1940
  TCP    192.168.1.100:49175    66.249.90.104:80       ESTABLISHED     1644
  TCP    192.168.1.100:49176    64.233.169.113:80      ESTABLISHED     1644

C:\Users\Steve Aplin>
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby MC10 » 27. February 2010 19:09

The second and third are Apache and MySQL.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: localhost does not display -- Windows 7 system

Postby Altrea » 27. February 2010 19:14

MC10 wrote:The second and third are Apache and MySQL.


You're wrong. 192.168.1.100 looks like his local Router IP.
e.g.: 66.249.90.104 is the IP of Google
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 28. February 2010 14:39

so port 80 is still open, and Apache still can't lock on to it. I wonder if this has anything to do with the fact that the "start" buttons in the xampp control panel don't change to "stop" when the svc boxes are unticked.
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 28. February 2010 14:45

Sure, the start buttons don't change their state, because Apache can't start successful.
But i'm not sure if this is a problem of blocked ports.

Maybe your Firewall blocks Apache to bind this port!?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 28. February 2010 16:09

well, I checked and Apache and MySQL were both blocked from inbound and outbound connections. They are now both allowed access, but still localhost won't launch.
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby steveo » 28. February 2010 18:45

agh!! problem solved!! I rebooted after giving Apache and MySQL access, and voila! Thanks very much for your help!
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 28. February 2010 19:16

^^

sometimes it can be such an easy thing
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby orit » 01. March 2010 20:21

Hi Steveo!
You said the problem was solved once you gave Apache and mysql access. Access to what?? Firewall? I also gave it access but it didn't help.
I have the same problem. I have windows 7 as well. I'm using AVG Internet security, and I actually noticed there that the service for Apache was not allowed, but then I allowed it, and it still wouldn't start. Perhaps another service name that I should allow?
i have this in the error log:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
orit
 
Posts: 2
Joined: 01. March 2010 20:04

Re: localhost does not display -- Windows 7 system

Postby Altrea » 02. March 2010 04:53

Try the netstat command i posted to check, if another process is blocking port 80
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby kp555 » 02. March 2010 19:09

I may have a similar problem to his, but I am using XP SP2. My issue is that Apache would not start and gives me an error message, please see the screen shot. I cannot access http://localhost/ or http://127.0.0.1/ and all my firefox says is "Unable to connect"

I installed/reinstalled it at C:\ (even at D:\ it dit not work), checked the port (see screenshot below), checked the services (no instance of Apache), and deleted and added the exception on Windows Firewall and still I could not start Apace, restarted the PC, all possible way that I could think of does not work.

Image

Image


It is my first time to install and use XAMMP, may you help me? :|
kp555
 
Posts: 11
Joined: 02. March 2010 16:59

Re: localhost does not display -- Windows 7 system

Postby Altrea » 02. March 2010 21:19

kp555 wrote:My issue is that Apache would not start and gives me an error message

Does the Apache error.log showes something more?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

PreviousNext

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests