localhost does not display -- Windows 7 system

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 14:20

Hello Forum,

I successfully installed xampp (as C:/xampp, not C:/program files/xampp), the control panel is working, no errors in the Apache error log, but I can't get the localhost screen to display. IE tells me "Internet Explorer cannot display the webpage," and the Diagnose Connection Problems button doesn't produce any results.

Any ideas what's going on?

Thanks!
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 14:32

steveo wrote:I successfully installed xampp

Installed as Administrator?

steveo wrote:(as C:/xampp, not C:/program files/xampp)

Thumb up :D

steveo wrote:the control panel is working

only the control panel, or can you start Apache and MySQL?

steveo wrote:Any ideas what's going on?

Not yet. Can you post us your hosts file? (C:\Windows\system32\drivers\etc\)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 14:41

Altrea, thanks for your quick reply.

Installed as Administrator?


Since I don't know what that means, probably not!

only the control panel, or can you start Apache and MySQL?


Both the control panel and yes Apache and MySQL both running.

My hosts file:
Code: Select all
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 14:54

steveo wrote:
Installed as Administrator?


Since I don't know what that means, probably not!

I don't have my Win7 here. But it should be somthing like "Right click on any executable file => run as administrator" or something like that.


steveo wrote:My hosts file:
Code: Select all
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost


delete the # in front of the line "127.0.0.1 localhost", or simply write "127.0.0.1 localhost" beneath it.
try to save the file (i hope Win7 will let you ^^)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 15:15

okay, was able to make the change in the file "Hosts" -- I just added "127.0.0.1 localhost" below the line that has the # in it.

And yes, right-clicking on an .exe gives you the option to Run as Administrator. I presume you want me to do that with the xampp control panel?

If yes, here's a weird thing. I go to stop Apache and MySQL, by clicking on the corresponding Stop buttons in the control panel. The script below indicates that they're both stopped, but both their Stop buttons are still active.
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 15:36

steveo wrote:And yes, right-clicking on an .exe gives you the option to Run as Administrator. I presume you want me to do that with the xampp control panel?


No. I want you to have done this to the xampp installation file ^^


steveo wrote:If yes, here's a weird thing. I go to stop Apache and MySQL, by clicking on the corresponding Stop buttons in the control panel. The script below indicates that they're both stopped, but both their Stop buttons are still active.

have you activated the svc checkboxes?
can you find the httpd and mysqld process in your task manager processes tab ?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 15:41

so delete xampp and reinstall, this time as administrator?
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 15:46

first try to access your xampp page with http://127.0.0.1 instead of localhost
if this fails, you can give the reinstall a try
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 17:00

okay, it's reinstalled and I ran the installation as Administrator.

Now xampp control panel is running with ticks in the "svc" boxes beside Apache and MySQL. I click on the start buttons, and nothing happens; I try to de-click the svc boxes and I get a dialog telling me to click OK if I want to uninstall the service.

Still no action with localhost (either as localhost or http://127.0.0.1); IE still can't display the page.
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 17:27

You don't have to tick the svc checkboxes. Please uncheck them.
If they are unchecked, start your Apache and MySQL in the control Panel (just click the start buttons)
next to the buttons have to appear green "running" boxes and the buttons change their value to "stop".

If this is done, try to access http://localhost/ or http://127.0.0.1
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 20:13

I didn't actually check the svc boxes; they were checked by default when I opened the control panel. Anyhow, I unchedked them only to get the same result: IE can't connect to localhost or to http://127.0.0.1.

Might be because the Start buttons corresponding with Apache and MySQL don't turn to Stop after I click on them (the green "running" boxes don't appear either), even though the script below indicates both are running.

Could this just be a basic non-compatibility issue between xampp and Windows 7? I have used xampp before, with XP pro and XP pro media, and didn't have these problems.
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 20:53

several users got XAMPP running on a Windows 7 without any problems, some others reported some difficulties.
please check your Apache error.log file if it can give us a hint whats going wrong.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 26. February 2010 21:01

ahh... okay, this morning there wasn't anything in the Apache error log but now there is. It appears to be the same error over and over, but I'll include all the contnents of the file just in case:
Code: Select all
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions.  : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Re: localhost does not display -- Windows 7 system

Postby Altrea » 26. February 2010 21:53

looks like there is anything else listening already on port 80.

please open your command-line and execute this command:

Code: Select all
netstat -aon | find ":80"


It will output all processes using port 80
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost does not display -- Windows 7 system

Postby steveo » 27. February 2010 15:34

okay, here's what it said:
Code: Select all
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Willie Stark>netstat -aon | find ":80"
  TCP    0.0.0.0:8093           0.0.0.0:0              LISTENING       1768

C:\Users\Willie Stark>
steveo
 
Posts: 15
Joined: 26. February 2010 14:11

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests