XAMMP-- Apache not running, port 80 already in use.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMMP-- Apache not running, port 80 already in use.

Postby mkdowning » 26. February 2010 00:41

Okay, so I've seen similar questions on here, but nothing that helped me out, so I'm sorry ahead of time if this question has already been answered.
I have installed Xampp 1.7.3 on my computer, to locally run Joomla.
I have only gotten Xampp to run right once, and I can't really tell what the difference is. The problem is, that port 80 is already occupied by a system process. I have tried several ways already to free up this port, to no avail. I have disabled IIS, among other things, I don't have Skype installed, and I've tried it with every other program closed I could possibly. I even tried changing the port number in the config files to something that's not in use, and that hasn't worked either. This is just effecting the Apache part of Xampp, the MySQL part is running fine, even though I obviously can't use it.

Any ideas? I am running Windows 7 as well by the way. Thanks for any help!
mkdowning
 
Posts: 2
Joined: 26. February 2010 00:34

Re: XAMMP-- Apache not running, port 80 already in use.

Postby thuyquai » 26. February 2010 03:12

You could run XAMPP and port-check it to see what process is using port 80
thuyquai
 
Posts: 2
Joined: 25. February 2010 08:02

Re: XAMMP-- Apache not running, port 80 already in use.

Postby mkdowning » 26. February 2010 06:07

It just says "System". But, I did manage to fix this, and since this is a common problem, I will share. Port 80 on windows 7 is occupied by a program called "World Wide Web Publishing Service". Not sure what it does, don't really care either, I've had it turned off for awhile now and nothing dire has happened. So, to turn this off, right click on "computer", click on "manage", click on "service & applications", then click on "services", and then scroll down to "world wide web publishing service". Right click on it, and tell it to "stop"! This fixed my problem INSTANTLY!!
mkdowning
 
Posts: 2
Joined: 26. February 2010 00:34

Re: XAMMP-- Apache not running, port 80 already in use.

Postby MC10 » 26. February 2010 07:54

I think that's just a problem with your computer; mine is also running Windows 7 and it runs XAMPP perfectly fine without messing around with port 80.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: XAMMP-- Apache not running, port 80 already in use.

Postby Znote » 26. February 2010 13:40

Worked out of the box on my Windows 7 computer as well.
Znote
 
Posts: 20
Joined: 17. November 2008 18:15

Re: XAMMP-- Apache not running, port 80 already in use.

Postby jimmmy » 26. March 2010 03:14

mkdowning you are the man! Thanks for sharing, this solved my problem instantly after hours of trawling google.

(I am on windows 7, too btw)

Jimmy
jimmmy
 
Posts: 4
Joined: 26. March 2010 03:10

Re: XAMMP-- Apache not running, port 80 already in use.

Postby MC10 » 27. March 2010 05:09

That meant that IIS wasn't disabled completely.
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: XAMMP-- Apache not running, port 80 already in use.

Postby vishal.wadkar86 » 19. April 2011 08:28

Hi Guys,

Even I am on Windows 7 machine. But I had not faced this problem before. But now when I stopped that WWW Publishing service Apache worked like a charm.

Thanks a lot!

R
vishal.wadkar86
 
Posts: 1
Joined: 19. April 2011 08:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests