"Waiting for localhost" messages: Found my fix!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

"Waiting for localhost" messages: Found my fix!

Postby Mobius » 24. February 2010 22:30

There seem to be a lot of messages regarding XAMPP installations with the result of "Waiting for localhost..."

Me, too. Is this normal to have so many non-starting installations after a release? XAMPP 1.7.3 is not a beta, is it?

I am new to XAMPP, and after installing XAMPP, I am getting the same message.

I have read lots of the forum posts, but I am not seeing any solutions.

My configuration: Windows XP SP2, XAMPP 1.7.3, 2G RAM, lots of hard drive space, installed in C:\ (which means that XAMPP is installed in C:\XAMPP, as you see below in the Port-Check output.), tried Apache and MySQL both in service and non-service modes. Tried FF, IE, Safari, Chrome, Opera, and SeaMonkey. I would bet that is it a wrong setting in a config file that got put in the 1.7.3 distribution accidentally, except that others are reporting that the issue is occuring in older versions of XAMPP. Can't wait for the solution to appear. I am willing to read on how to troubleshoot the installation if someone would point me to the documentation. XAMPP Control Panel Application works. "Status Check OK" I can start and stop Apache, MySQL, etc. I tried different firewalls, and turned my firewall off, too. Nothing works (except the message: Waiting for localhost..., that works just fine.) I tried http://localhost/ and http://127.0.0.1/ Firebug and Web Developer View Source return completely blank results. I am getting no other or error messages of any kind.

Is there a known-to-work version of XAMPP?

Mobius

Code: Select all
Service              Port   Status
==================================================================
Apache (HTTP)          80   Program: C:\xampp\apache\bin\httpd.exe
Apache (WebDAV)        81   free
Apache (HTTPS)        443   Program: C:\xampp\apache\bin\httpd.exe

MySQL                3306   Program: C:\xampp\mysql\bin\mysqld.exe

FileZilla (FTP)        21   free
FileZilla (Admin)   14147   free

Mercury (SMTP)         25   free
Mercury (POP3)        110   free
Mercury (IMAP)        143   free
Mercury (HTTP)       2224   free
Mercury (Finger)       79   free
Mercury (PH)          105   free
Mercury (PopPass)     106   free

Tomcat (AJP/1.3)     8009   free
Tomcat (HTTP)        8080   free
Last edited by Mobius on 25. February 2010 00:27, edited 1 time in total.
Mobius
 
Posts: 8
Joined: 24. February 2010 00:48

Re: There seem to be a lot of "waiting for localhost" messages.

Postby Nobbie » 24. February 2010 23:26

Mobius wrote:Is there a known-to-work version of XAMPP?


Ridicolous. You screwed up your PC, not Xampp.

"A fool with a tool remains a fool".
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: There seem to be a lot of "waiting for localhost" messages.

Postby Mobius » 25. February 2010 00:25

Nobbie wrote:
Mobius wrote:Is there a known-to-work version of XAMPP?


Ridicolous. You screwed up your PC, not Xampp.

"A fool with a tool remains a fool".


I am not quite sure what you mean by that comment. Windows is working fine.

REGARDLESS, I found my fix.

I do not know if it was on apachefriends.org or nyphp.org/phundumentals

I went to c:\xampp\apache\conf\extra and opened, in a text editor, the file: httpd-mpm.conf

The next to the last line in that file says:
#Win32DisableAcceptEx

I deleted the "#", so as to uncomment that line.

Now, it appears that XAMPP/Apache is working.

OK, I found the fix at:

http://www.apachefriends.org/en/faq-xam ... ml#nostart

under the subheading of: My CPU load is with the Apache almost by 99%

which is right under the subheading: The apache does not start on my system!!!

... or your browser can connect to the server, but doesn't show anything (always trying to load the page). In this case remove the "#" at the line "#Win32DisableAcceptEx" in the file "\xampp\apache\conf\extra\httpd-mpm.conf". Or add this line at the end, if not exists. Should be:
Win32DisableAcceptEx
[/quote]

I hope this helps others.
Mobius
 
Posts: 8
Joined: 24. February 2010 00:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests