Cant connect to localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cant connect to localhost

Postby martyjones » 14. February 2010 05:22

Hello all. I installed Xampp about a week ago to develop my wordpress blog. For the first 2 days, Xampp worked great, mysql and apache started fine. Day 3, I open up xampp, start apache and mysql (control panel said they started fine), and tried to connect to localhost. Nothing. I tried to stop apache and mysql. Control panel reported that they stopped just fine, but the green "Running" box was still going beside both, so I'm assuming they wont shut down for some reason. I've tried:

-Uninstalling Skype
-Editing my hosts file to comment out the line that seems to cause problems.
-Changing apache from port 80
-Making sure my firewall is allowing port 80
-Running Xampp as administrator
-Uninstalling and reinstalling Xampp

Also, when I run a port-check, ports 80, 443, and 3306 all show up free, when they should be taken up by the Xampp services.

I'm utterly at a loss.
martyjones
 
Posts: 5
Joined: 14. February 2010 05:13

Re: Cant connect to localhost

Postby Nobbie » 14. February 2010 11:17

Before doing anything, i would look into the logfiles. Did you?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: Cant connect to localhost

Postby martyjones » 14. February 2010 18:10

Nobbie, thanks for the quick response. Here is the apache error.log:

Code: Select all
[Fri Feb 12 09:20:00 2010] [notice] Digest: generating secret for digest authentication ...
[Fri Feb 12 09:20:00 2010] [notice] Digest: done
[Fri Feb 12 09:20:01 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Feb 12 09:20:01 2010] [notice] Server built: Nov 11 2009 14:29:03
[Fri Feb 12 09:20:01 2010] [notice] Parent: Created child process 6032
[Fri Feb 12 09:20:03 2010] [notice] Digest: generating secret for digest authentication ...
[Fri Feb 12 09:20:03 2010] [notice] Digest: done
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Child process is running
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Acquired the start mutex.
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Starting 150 worker threads.
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Starting thread to listen on port 80.
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Starting thread to listen on port 443.
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Starting thread to listen on port 443.
[Fri Feb 12 09:20:03 2010] [notice] Child 6032: Starting thread to listen on port 80.
[Fri Feb 12 09:20:26 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/wordpress
[Fri Feb 12 12:01:04 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/wp-admin/plugin-install.php?tab=search
[Fri Feb 12 12:06:09 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/wordpress
[Fri Feb 12 12:06:09 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/xampp/wordpress
[Fri Feb 12 12:06:54 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico
[Fri Feb 12 13:47:11 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/
[Fri Feb 12 13:47:18 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/
[Fri Feb 12 13:55:56 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/
[Fri Feb 12 13:55:58 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/
[Fri Feb 12 13:56:30 2010] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/favicon.ico, referer: http://localhost/wordpress/
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address [::]:80


The last line made me think that port 80 is occupied, but when I ran a port check, as I said, all ports show up free.
martyjones
 
Posts: 5
Joined: 14. February 2010 05:13

Re: Cant connect to localhost

Postby Wiedmann » 14. February 2010 18:27

Code: Select all
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address [::]:80

The last line made me think that port 80 is occupied, but when I ran a port check, as I said, all ports show up free.

I'm not sure at the moment if the port-check is testing for IPv6. So it might be possible that port 80 is free for IPv4, but not for IPv6.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cant connect to localhost

Postby martyjones » 14. February 2010 19:20

I gave it a switch over to IPv4, no change.
martyjones
 
Posts: 5
Joined: 14. February 2010 05:13

Re: Cant connect to localhost

Postby Wiedmann » 14. February 2010 19:29

I gave it a switch over to IPv4,

This means exactly?

no change.

So you have still the same error message in the error.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cant connect to localhost

Postby martyjones » 14. February 2010 19:57

Wiedmann: I changed Xampp's settings to enable IPv4/6 instead of IPv6, which was the previous setting.

The error log has added the following lines:

Code: Select all
no listening sockets available, shutting down
Unable to open logs
[Sun Feb 14 12:50:57 2010] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Feb 14 12:50:58 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 14 12:50:58 2010] [notice] Digest: done
[Sun Feb 14 12:50:59 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Feb 14 12:50:59 2010] [notice] Server built: Nov 11 2009 14:29:03
[Sun Feb 14 12:50:59 2010] [notice] Parent: Created child process 4888
[Sun Feb 14 12:51:01 2010] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 14 12:51:01 2010] [notice] Digest: done
[Sun Feb 14 12:51:01 2010] [notice] Child 4888: Child process is running
[Sun Feb 14 12:51:01 2010] [notice] Child 4888: Acquired the start mutex.
[Sun Feb 14 12:51:01 2010] [notice] Child 4888: Starting 150 worker threads.
[Sun Feb 14 12:51:01 2010] [notice] Child 4888: Starting thread to listen on port 443.
[Sun Feb 14 12:51:01 2010] [notice] Child 4888: Starting thread to listen on port 80.
martyjones
 
Posts: 5
Joined: 14. February 2010 05:13

Re: Cant connect to localhost

Postby Wiedmann » 14. February 2010 21:41

From the log you XAMPP is running...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Cant connect to localhost

Postby martyjones » 14. February 2010 22:41

I know. As I've said, Xampp reports that it is working just fine.. Yet I can't connect to my localhost, nor can I shut mysql or apache off once I've turned them on.
martyjones
 
Posts: 5
Joined: 14. February 2010 05:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests