Apache Server Starts and Stops

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Server Starts and Stops

Postby vcmnetwork » 13. February 2010 18:06

I just installed XAMPP and was attempting to test my installation of Apache. Under the XAMPP Control Panel, I clicked the start button next to Apache. The green bar indicating "running" appears briefly and stops. Performed this task multiple time with the same results. I opened my services control panel on my desktop by entering "services.msc" in the run window under the start menu. I attempted to start the Apache service from there, but it stops soon after it starts. I get the following message after it fails to start:

"The Apache 2.2 service on you local computer started and then stopped. Some services stop automatically if they have not work to do, for example, the Performance Logs and Alert service."

MySQL and Filezilla start and remain active, so the problem is isolated to the Apache install. I am unable to access http:/localhost in my browser to test the server. I have searched previous post and either could not find a solution that worked for me or was applicable to my circumstance. Any help would be greatly appreciated.
Posts: 2
Joined: 11. February 2010 23:17

Re: Apache Server Starts and Stops

Postby Altrea » 15. February 2010 06:14

a look in your apache error.log file should help to analyse your problem. Maybe your Apache port is already in use, maybe anything else.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
AF Moderator
Posts: 8243
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache Server Starts and Stops

Postby batmania » 15. February 2010 11:02

Disable other servers. Example:
xampp control panel -> SCM -> Stop service "IIS"
Good day
Posts: 1
Joined: 15. February 2010 10:45

Re: Apache Server Starts and Stops

Postby LooseCannon » 15. February 2010 13:02

Check your vhost configs. An error there causes the start-the-stop issue for me. XAMPP checks the Apache config at startup?
User avatar
Posts: 162
Joined: 18. September 2007 12:07
Location: Hampshire, UK

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests