Start Apache Server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Start Apache Server

Postby vcmnetwork » 11. February 2010 23:34

I just installed XAMPP and was attempting to test my installation of Apache. Under the XAMPP Control Panel, I clicked the start button next to Apache. The green bar indicating "running" appears briefly and stops. Performed this task multiple time with the same results. I opened my services control panel on my desktop by entering "services.msc" in the run window under the start menu. I attempted to start the Apache service from there, but it stops soon after it starts. I get the following message after it fails to start:

"The Apache 2.2 service on you local computer started and then stopped. Some services stop automatically if they have not work to do, for example, the Performance Logs and Alert service."

MySQL and Filezilla start and remain active, so the problem is isolated to the Apache install. I am unable to access http:/localhost in my browser to test the server. I have searched previous post and either could not find a solution that worked for me or was applicable to my circumstance. Any help would be greatly appreciated.
vcmnetwork
 
Posts: 2
Joined: 11. February 2010 23:17

Re: Start Apache Server

Postby Wiedmann » 11. February 2010 23:46

I have searched previous post and either could not find a solution that worked for me or was applicable to my circumstance.

Reading the "error.log" is always applicable.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Start Apache Server

Postby DentonAnderson » 12. February 2010 02:45

I have the same problem. The only difference is that I do not get any message, it just does not run. I have looked at the error.log file in XAMPP\apache\logs, and it is completely empty. I have tried installing different versions with the same result.
DentonAnderson
 
Posts: 2
Joined: 12. February 2010 02:36

Re: Start Apache Server

Postby keress » 12. February 2010 17:05

I am also having this problem, though I am getting an error log at xampp>apache>logs:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


Any help would be greatly appreciated.
keress
 
Posts: 1
Joined: 12. February 2010 17:00

Re: Start Apache Server

Postby DentonAnderson » 12. February 2010 18:48

I have found the solution to my problem in an earlier post below:

Apache server does not started
by geojay » 10. February 2010 14:59

hanswurst123 wrote:
Or maybe Skype running? I had the same error, closing Skype solved it

You can set Skype to stop listening on port 80 (and 443) by going to Tools -> Options... -> Advanced -> Connection and unticking "Use port 80 and 443 as alternatives for incoming connections"

I should think this will be a common problem so maybe should be added as a sticky or similar?
DentonAnderson
 
Posts: 2
Joined: 12. February 2010 02:36


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests