Authentication required

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Authentication required

Postby lucky_cavalry » 09. February 2010 22:21

Hi everybody,

I had used xampp several times but I'm not an advanced user. Now I need really experts' help to solve my problem related to authentication.
Today, I've installed xampp on a server within my company network. I installed some php+mysql applications there and it worked fine, until I've decided to open that server to public.
That server is now open to outside my company network.
I can reach my application via http://mysubdomain.mycompanydomain/myapp whenever I browse within my company network, but that link does not work properly outside the network. Instead it shows me a popup saying "Authentication Required" and asking credentials.

Today I've crawled the web but couldn't find a clear guide to understand the authentication and security issues and solve my problem. I don't want to create a security gap while opening my app outside the company.

What would your advice be?
Thanks in advance.
lucky_cavalry
 
Posts: 3
Joined: 09. February 2010 22:08

Re: Authentication required

Postby Wiedmann » 09. February 2010 23:50

I can reach my application via http://mysubdomain.mycompanydomain/myapp whenever I browse within my company network, but that link does not work properly outside the network. Instead it shows me a popup saying "Authentication Required" and asking credentials.

This message is from XAMPP/Apache?
--> see the error/access.log
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Authentication required

Postby lucky_cavalry » 10. February 2010 08:12

I can't see any errors in access.log or I don't understand. All successful and and unsuccessful attempts are logged in similar way there.
I've also looked in errors.log:

[Tue Feb 09 23:41:23 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 09 23:41:23 2010] [notice] Digest: done
[Tue Feb 09 23:41:24 2010] [notice] Child 5104: Child process is running
[Tue Feb 09 23:41:24 2010] [notice] Child 5104: Acquired the start mutex.
[Tue Feb 09 23:41:24 2010] [notice] Child 5104: Starting 150 worker threads.
[Tue Feb 09 23:41:24 2010] [notice] Child 5104: Starting thread to listen on port 443.
[Tue Feb 09 23:41:24 2010] [notice] Child 5104: Starting thread to listen on port 80.

Do these make any sense?
lucky_cavalry
 
Posts: 3
Joined: 09. February 2010 22:08

Re: Authentication required

Postby Wiedmann » 10. February 2010 08:29

I've installed xampp on a server within my company network.

I estimate you spoke already with your company network administrator?
(So it's verified, http requests are routed to your pc and also not blocked by a company firewall.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Authentication required

Postby lucky_cavalry » 10. February 2010 08:36

You are right, I've spoken to network admin and they say like you estimated.
Unfortunately they don't have any idea about apache server, they are from iis world.
lucky_cavalry
 
Posts: 3
Joined: 09. February 2010 22:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests