Apache server does not started

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache server does not started

Postby klstrfr » 07. February 2010 15:47

Hello, its my first time with apache. I've downloaded the .zip archive and extracted to C:\xampp. When I want to start the appache server with "apache_start.bat" i become the message: "apache" is not started. Even if i turn off my firewll. Can anyone help me?
klstrfr
 
Posts: 2
Joined: 07. February 2010 15:37

Re: Apache server does not started

Postby Wiedmann » 07. February 2010 16:03

When I want to start the appache server with "apache_start.bat" i become the message: "apache" is not started.

Read the "error.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache server does not started

Postby klstrfr » 07. February 2010 16:05

(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
this is the content of my error.log
klstrfr
 
Posts: 2
Joined: 07. February 2010 15:37

Re: Apache server does not started

Postby Wiedmann » 07. February 2010 19:47

(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder Anschluss) nur jeweils einmal verwendet werden. :

So there is already a server running. Stop this server, and you can start Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache server does not started

Postby hanswurst123 » 10. February 2010 22:23

Or maybe Skype running? I had the same error, closing Skype solved it ;)
hanswurst123
 
Posts: 1
Joined: 10. February 2010 22:20

Re: Apache server does not started

Postby geojay » 10. February 2010 23:59

hanswurst123 wrote:Or maybe Skype running? I had the same error, closing Skype solved it ;)


You can set Skype to stop listening on port 80 (and 443) by going to Tools -> Options... -> Advanced -> Connection and unticking "Use port 80 and 443 as alternatives for incoming connections"

I should think this will be a common problem so maybe should be added as a sticky or similar?
geojay
 
Posts: 12
Joined: 09. February 2010 13:44


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests