Can't launch apache -NULL driver issue

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't launch apache -NULL driver issue

Postby keben » 04. February 2010 12:31

hi
I'am trying to re install the new version of xampp on a windows FLP but it looks like i can't go through the entire process and can't launch the apach server.
my config : windows FLP + Eset nods 32 + no firewall activated + no msn or skype

I tried to go through the installer to install xampp on a D: partition... the dezipping goes well... but just after when the dos windows open i got :
- three line with : can't find specified file (or something like that)
- then the xampp setup require me to chose (1-0/x)... but i don't know to what it's refer, and anyway i tried every solution without success...so hit x

bAck to the folder ...xampp is installed and i try to relocate file, so launch setup_xampp.bat..and come back to the previous xampp setup request (1-0/x)...so hti x

so i launch xampp control pannel and try to launch mysql...it launch perfectly (running)....but when i try apache.... it' can't
i launch the port-check... and 80 and 443 looks free
and the log of apache give this :
Can't open nul : no such file or directory
perl_parse : no such file or directory

Any help would be most welcome!

i forgot to tell that i checked netstat with no result
Last edited by keben on 05. February 2010 09:14, edited 1 time in total.
keben
 
Posts: 3
Joined: 04. February 2010 12:11

Re: Can't launch apache

Postby Wiedmann » 04. February 2010 12:39

Code: Select all
Can't open nul : no such file or directory

Any help would be most welcome!

The NUL device is missing in your Windows installation.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't launch apache

Postby keben » 04. February 2010 13:00

First , thanks for replying.
Could you help me a little further as to identify what is a NUL device?? is it mandatory to run apache and eventually how i can have it installed?

Could it be a side of windows FLP?
keben
 
Posts: 3
Joined: 04. February 2010 12:11

Re: Can't launch apache

Postby Wiedmann » 04. February 2010 13:40

is it mandatory to run apache

Yes.

how i can have it installed?

I don't know. You better ask this question in a Microsoft Windows Support Forum (or call Microsoft).

Could it be a side of windows FLP?

I guess. But have never seen this Windows FLP.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't launch apache

Postby keben » 04. February 2010 17:33

ok
i solved my issue as windows FLP (Windows Fundamentals for Legacy) wich is a windows embed does not support Null device, you can bypasse that issue using the link just under who provide a reg and install bat in order to implement the NULL device

http://www.cynosurex.com/Forums/DisplayComments.php?file=Batch/NUL_Missing_on_WinFLP

With that installed you can perform the xampp installer without any issue.

I think this can be of interest for all people using mini pc with embeded xp on it...

Thanks for the help you gave me Wiedmann in finding a solution to my issue
keben
 
Posts: 3
Joined: 04. February 2010 12:11


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests