Can`t send emails...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can`t send emails...

Postby psicloone » 03. February 2010 23:48

I need to configure mailserver so that I can send emails for forgotten passwords (under XAMPP, windows 7).

Tried sendmail - it didn`t work (it didn`t show error, but the message did not arrive).

I tried mercury with the google mail server as this pictures show:

It didn`t work.

I tried phpmailer - it didn`t work.

What could be the reason?
Posts: 2
Joined: 19. June 2009 12:23

Re: Can`t send emails...

Postby Willy92 » 24. February 2010 06:18

IF you are using a windows based version you will need to set the smtp settings in php.ini AND the sendmail settings in sendmail.ini The sedmail.ini can also take a username and password if your isp requires it - or do a pop before smtp. I have taken a lot of time to get it working for me but it now works fine. Check both of those ini files to see if they are configured with your info.
Posts: 7
Joined: 01. April 2009 15:48

Re: Can`t send emails...

Postby rmdave » 25. February 2010 19:47

XAMPP 1.7.3 + Windows XP Pro + Default installation

The last line account default needs to be set to the 'account' entry you want to use in the file above. By default it is set to use the Mercury configuration that goes to localhost.

These settings worked for me:

Code: Select all
# A freemail service example
account Gmail
tls on
tls_certcheck off
port 587
auth on
password mysecret

# Set a default account
account default : Gmail

And, I removed semi-colon in front of this line in php.ini:

Code: Select all

sendmail_path = "\"C:\xampp\sendmail\sendmail.exe\" -t"

Posts: 1
Joined: 25. February 2010 19:37

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 20 guests