Can't access Mercury Mail from CP.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't access Mercury Mail from CP.

Postby whiterican » 28. January 2010 20:58

I am Trying to set up Mercury Mail on with Xampp on my network and I cannot access the admin panel through it the cp. Not only that I cannot get MM to show pop3 as working. Only Imap.

Windows 7 64 Xampp 1.7.3 installed. Everything else works Just fine but Given that I am trying to test it simply for an at home family site I cannot do the above. How Do I fix this issue?

Ideas Please.

Johnmf2005@live.com
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby whiterican » 29. January 2010 03:33

Ok even after telling windows to allow/// I still cannot access the email? Xampp control panel refuses to start admin for Mercury Mail and I have to go to folder where exe file is to load it. I no have everything but the interface showing up. port check clear.. All ports for Mercury taken up by mercury.

However I cannot login now to the accounts. Even as admin...

Any suggestions PLEASE.

Whiterican
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby Wiedmann » 29. January 2010 07:34

Xampp control panel refuses to start admin for Mercury Mail

Are your running Mercury as a service (svc)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't access Mercury Mail from CP.

Postby whiterican » 29. January 2010 16:28

Yes I am. I have done this with all other portions of xampp. (apache,php,and filezilla) Just having issues with Mercury Mail.
That's the confusing part why all else works and MM. doesn't.

any suggestions please feel free.

White
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby whiterican » 29. January 2010 16:37

Should run Mercury on it's own, or will as a service work?
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby whiterican » 30. January 2010 17:59

This is a re-post for clarity. I have upgraded to the newest Xampp 1.7.3 on a Windows 7 64 ultimate and am just now trying to configure Mercury Mail and would like to know a couple of things. 1) how to get MM to communicate with the CP and 2) How to properly set it up so that it will use my domain name for email services.
Thanks

White
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby Wiedmann » 30. January 2010 18:51

Are your running Mercury as a service (svc)?

Yes I am.

Untick the SVC checkbox and try again.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't access Mercury Mail from CP.

Postby alhowe » 31. January 2010 16:14

I also am having trouble getting Mercury Mail to work properly. I am following the guidelines in "e-Start Your Web with Zen Cart". I am running Windows 7 Professional (x64). I have installed xampp 1.7.3 (exe version). I have modified my hosts file (set up my local domain). I have modified the apache httpd.conf file. I have set up apache, mysql and mercury mail as services. Everything worked fine to this point. I then stopped the mercury service, modified the mercury.ini file and restarted the mercury service. But when I try to send a test email from postmaster@example.com to admin@example.com, I get an error message that the mail server is not working correctly. I suspect there may be a problem with the UAC but cannot confirm this. I have this same system installed on my laptop running Windows XP (x86) and everything works fine.

Any help would be greatly appreciated.

Tks, Al
alhowe
 
Posts: 2
Joined: 31. January 2010 16:02

Re: Can't access Mercury Mail from CP.

Postby whiterican » 31. January 2010 18:00

OK So MM works not as a service.

I unchecked the box and it started up just fine. Thanks For your help

White.
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby alhowe » 31. January 2010 19:11

Only my earlier post today, I thought my problem was my UAC. On reading other posts in other areas, it seems that my problem was most likely the php5+. I uninstalled xampp 1.7.3 and installed 1.7.1 and everything is now working fine with one exception. I cannot get my Mercury to run as a service. The check box in xampp control panel will not let me select Mercury. I have tried to start it using the c:\xampp\xampp_service_mercury.exe but I couldn't get it to work. I don't get any error messages or anything. I am also assuming that is the purpose of that file. But it looks like I am wrong. If anyone knows how to start Mercury as a service in xampp 1.7.1, please let me know.

Tks,
Al
alhowe
 
Posts: 2
Joined: 31. January 2010 16:02

Re: Can't access Mercury Mail from CP.

Postby whiterican » 31. January 2010 20:06

Wiedmann,


It seems none of the servers/clients are running except http and imap... what Do I need to do to ensure the rest are working?

White
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby Wiedmann » 31. January 2010 20:14

It seems none of the servers/clients are running except http and imap... what Do I need to do to ensure the rest are working?

Hm, somewhere in the Mecury Admin --> Configuration you can enable/disable the protocol modules.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't access Mercury Mail from CP.

Postby whiterican » 31. January 2010 20:54

According to the admin panel all is well I will search to find whether I can enable them manually.. Might need pointers though.

white
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby whiterican » 31. January 2010 21:00

I am thinking problem with install as well and going to work with mercury as needed.


edit today

yes there was an issue with install. However, After reading some more posts.. I have a question about the sendfile/php thing.

viewtopic.php?f=16&t=38648&p=154326&hilit=+sendmail+sendmail+edit#p154326

Is the only setup with either sendfile or php basically a spoof or more likely IMO a redirect from MM to the appropriate email server you would normally use for email?

And

Another thing since I have multiple DNS names for various at home sites what would be the best way to allow them to function at home?

white
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19

Re: Can't access Mercury Mail from CP.

Postby whiterican » 15. July 2010 22:45

The problem was the x module...

Once that was taken out of the picture all worked well.

Thanks white
whiterican
 
Posts: 32
Joined: 13. December 2009 02:19


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests