Xampp Apache start problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp Apache start problem

Postby richardpd » 25. January 2010 00:08

Hi
I can no longer start Apache in Xampp. When I click start in Xampp control panel it says.. Busy..Apache started.. but does not give the Running message and does not start!
I uninstalled Xampp (saving htdocs and Mysql) and reinstalled but I have the same problem.
Now I do not know what the cause of this is or how to fix it & so presently do not have a working Xampp installation.
(I had been in the process of trying to get addon Tomcat working but cannot see how that could have caused any problem).

Can someone help me get Xampp to work correctly? I am on Vista 32 bit computer.
I look forward to helpful replies, many thanks
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54

Re: Xampp Apache start problem

Postby Wiedmann » 25. January 2010 00:42

Now I do not know what the cause of this is or how to fix it

Read the "error.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Xampp Apache start problem

Postby richardpd » 25. January 2010 01:10

Good idea to read the error log- thanks!

This is it:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80


Why has this happened when it was running fine a little while earlier? I don't know what has caused this and how to fix it!

I am grateful for some more help please...thanks
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54

Re: Xampp Apache start problem

Postby richardpd » 26. January 2010 21:32

Ok
I am posting an update as I have fixed my Xampp problem.
For some reason while I was trying to install Tomcat addon to my Xampp install the Apache server settings must have altered.
After I deleted & reinstalled Xampp (saving htdocs & Mysql data) Apache did not run at first as I had forgotten to edit my ports to the correct setting (I run RoR & IIS7 also on localhost ports and cannot use default values otherwise I get conflict!).
So when I reset Apache to the correct port it started again!

Then later I finally managed to get Tomcat running (I had to change my Catalina_Home env varaiable from C:\xampp\tomcat\bin to C:\xampp\tomcat- simple! except it took me so long to find that info - and of course I used a different port by editing server.xml).

Now I just need to check my htdocs & MySQL data are still sound after this-I hope so!

Regards
Richard
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54

Re: Xampp Apache start problem

Postby pdfsmail » 26. January 2010 21:54

I am a noob with xampp so bear with me...
I also have a start problem with apache.
Everything else will start except apache.
I installed my xampp on my D: drive
I have completely uninstalled then reinstalled xampp
I have checked my computer and nothing at all uses port 80
I have removed my firewall and antivirus and still get the following error, that I don't quite get:

Syntax error on line 7 of D:/1ASERVER/xampp/apache/conf/extra/httpd-xampp.conf:
SetEnv takes 1-2 arguments, an environment variable name and optional value to pass to CGI.

any ideas? I know what a syntax error is but i have no idea how to fix this....
I never altered the configuration file? Is there a setting or config I need to change?
help plz. :cry:
pdfsmail
 
Posts: 1
Joined: 26. January 2010 21:47

Re: Xampp Apache start problem

Postby cube » 27. January 2010 03:02

Hi,

can you post the contents of that file (especially around line 7!)

Thanks
cube
 
Posts: 4
Joined: 26. January 2010 21:24

Re: Xampp Apache start problem

Postby mkm854 » 27. January 2010 11:20

If have another local server first stop service that server than try to restart apache:

open control panel: click SCM button, you got services
mkm854
 
Posts: 5
Joined: 27. January 2010 10:26

Re: Xampp Apache start problem

Postby richardpd » 27. January 2010 11:58

Hi
I did an internet search last night for httpd-xampp.conf SetEnv but didn't find the answer (I found a lot of information on Xampp!). That file must have been altered but anyway it apparently has the wrong settings and as I am new to xampp I cannot advise how to edit it and as already posted perhaps you need to show the actual code here so someone can fix it for you.

Otherwise if you have no port conflicts (?Skype? or other?) I would try another reinstall. Make sure you completely remove the xampp folder before reinstall. Sometimes not all the files get deleted properly and occasionally you get a corrupt install. I would try deleting and reinstalling a new fresh good xampp install. Goodluck!

Do let us know if and how you managed to fix this, best regards
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54

Xampp Apache start problem nach Tomcat installation

Postby ProjectOne » 28. January 2010 02:56

Hi,
I also have problems to start the Apache after I installed Tomcat as Xampp-Plugin Apache starts no more.
extraction out out of Apache log:
"Syntax error on line 505 of I:/Program Files (x86)/Programmierung/Server/xampp/apache/conf/httpd.conf:
SSLSessionCache: Invalid argument: size has to be >= 8192 bytes"

How can I avoid such problems, everytime after I installed tomcat, apache can't start anymore.

Not the problem just now, but funny:
"Some time ago my apache error.log had about ~470MB :wink: Apache made at that time 99%CPU-usage, but caused from a other problem."

thank you for your help
ProjectOne
 
Posts: 1
Joined: 28. January 2010 02:34

Re: Xampp Apache start problem

Postby joost » 01. February 2010 10:51

Hello,,

I am having the same problem as richardpd after reinstalling xampp:

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80

He apperently solved it, but I don't understand how he did that.
Can someone enlighten me?

Thanks,
Joost
joost
 
Posts: 2
Joined: 01. February 2010 10:43

Re: Xampp Apache start problem

Postby richardpd » 01. February 2010 20:59

Hi Joost

I fixed my problem by editing the xampp apache httpd.conf file to have the correct port for apache (not conflicting with my IIS7 or RubyonRails port configuration).

To help you with this here is a link to a webpage briefly explaining how to edit the httpd.conf file:
http://blog.wolffmyren.com/2008/07/30/making-xampp-apache-work-with-iis-on-windows-xpvista/

Here is the brief outline instruction from that webpage:
C:\xampp\apache\conf\httpd.conf:
>>>>>>>>
Search for “Listen 80″, change to “Listen 8080″
Search for “ServerName localhost:80″, change to “ServerName localhost:8080″
C:\xampp\apache\conf\extra\httpd-ssl.conf

Search for “Listen 443″, change to “Listen 4499″
Search for “<VirtualHost _default_:443>”, change to “<VirtualHost _default_:4499>”
Search for “ServerName localhost:443″, change to “ServerName localhost:4499″
Then, you should be able to start Apache successfully through the XAMPP control panel.
<<<<<<<<<

So I advise you know what port you need your xampp apache localhost to run on & make sure you have no other port conflicts on your computer (including Skype) and edit your xampp apache httpd.conf to the port setting you need. OK?

(If you use Tomcat addon see my other post!). I hope this helps & you get your xampp apache server working again. Goodluck (do let us know if you succeed),regards

Richard
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54

Re: Xampp Apache start problem

Postby joost » 02. February 2010 08:11

Hi Richard,

I've edited the two config files and started apache and I can connect to http://localhost:8080/xampp/. Is there a way to get rid of the :8080 in this url?

One remark. When I run the port-check utility in the control panel, it gives me the following:

Service Port Status
Apache(HTTP) 80 Process: System

Which looks a bit odd to me. Everybody is talking about Skype, but I believe this is the kernel. Any ideas?

Anyway, thank you for your help.

Joost
joost
 
Posts: 2
Joined: 01. February 2010 10:43

Re: Xampp Apache start problem

Postby richardpd » 02. February 2010 21:02

Hi Joost

Glad you are getting sorted with xampp.
There is a way to change the url but I haven't tried it!
Here are x2 links from Google search with some information that may help.

1.How to assign a virtual domain name to your localhost.
http://www.trap17.com/index.php/assign- ... 63185.html

The notes here refer to Wamp rather than Xampp but I guess they apply.

2. How to Configure NameVirtualHost in XAMPP’s Apache Server

http://www.ardamis.com/2005/08/11/xampp ... rtualhost/

This link gives some detailed instruction for Xampp.

Goodluck with changing your url- I'm sure you will succeed!

Now about your port-check- I am sorry I don't know about this and haven't 'Googled' about it!
It is interesting but I am currently struggling myself with gtk+/gtkmm programming in Vista at the cmd prompt and other computer issues and do not have time to learn all Xampp features. I am happy to use xampp basically for my simple localhost server needs and I am learning about Xampp as I go and fitting it in around my other programming and life!
I am sure you will find the answer either on this forum or elsewhere.
Again goodluck and regards

Richard
richardpd
 
Posts: 13
Joined: 24. January 2010 23:54


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests