XAMPP-Netbeans debug unreliable

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP-Netbeans debug unreliable

Postby berniev » 20. January 2010 07:08

Using XAMPP 1.73, Netbeans 6.8 PHP, XP SP3, all default with recommended changes to php.ini re zend, xdebug etc.
I just can't get debug to work reliably. Same with 1.72 and earlier Netbeans.
Setting a watch is certain to crash with sockets error. Local variables not displayed.
After an error apache runs slow for quite some time, even after restarting all apps and apache.

Solutions I've seen are inconsistent and often address older versions.

Is there a definitive solution? XAMP is great, and as a relative noob I kinda expect this is a clean configuration and should almost work 'out of the box', but it doesn't.

Help? Please?
berniev
 
Posts: 6
Joined: 20. January 2010 06:46
Location: Sydney Australia

Re: XAMPP-Netbeans debug unreliable

Postby Izzy » 20. January 2010 07:14

Is Netbeans compatible with PHP 5.3 as both XAMPP 1.7.3 and 1.7.2 have PHP 5.3 included?

Perhaps check with their web site.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: XAMPP-Netbeans debug unreliable

Postby berniev » 20. January 2010 07:22

According to NetBeans web site re v6.8: "Supported technologies: ... PHP 5.3, 5.2, 5.1 ..."
However, had similar problems with earlier versions of XAMPP/Netbeans. Have been upgrading in tandem.
berniev
 
Posts: 6
Joined: 20. January 2010 06:46
Location: Sydney Australia


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests