Apache never starts

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache never starts

Postby thetravels » 20. January 2010 01:10

The Apache service named reported the following error:
>>>(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. :make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, sutting down
I have checked the ports at the command prompt and they are listening. Here is the page:

C:\Documents and Settings\Administrator>netstat -an |find "80"
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1801 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1092 72.247.146.10:80 CLOSE_WAIT

I also checked port 443 with the following results
TCP 0.0.0.0:443 0.0.0.0:0 LISTENING

I tried the xampp portcheck and it said that
SERVICE PORT STATUS
Apache <HTTP> 80 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Apache <WebDAV> 81 free
Apache <HTTPS> 443 C:\WINDOWS\system32\inetsrv\inetinfo.exe
So I am officially lost.
I am running XP pro sp3.
I tried running Apache from the Services (Local) but it just tells me it can not and to check the event log which is above.
I have already uninstalled and rolled my system back a couple of days to a clean configeration.
I have unselected the 80 443 ports on Skype
I have tried to start Apache with my firewall, antivirus off and no dice.
I installed Winsock2 XP fix but that did not work.
I have been stuck here for two days now, please help!
thetravels
 
Posts: 2
Joined: 20. January 2010 00:51

Re: Apache never starts

Postby Izzy » 20. January 2010 01:21

thetravels wrote:I tried the xampp portcheck and it said that
SERVICE PORT STATUS
Apache <HTTP> 80 C:\WINDOWS\system32\inetsrv\inetinfo.exe
Apache <WebDAV> 81 free
Apache <HTTPS> 443 C:\WINDOWS\system32\inetsrv\inetinfo.exe
This is the server that is listening on the ports that Apache requires exclusively and is the Windows IIS.

You will need to disable IIS:
viewtopic.php?f=16&t=38909&p=155293
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache never starts

Postby thetravels » 20. January 2010 03:28

wow. so cool. I now disabled IIS and all works. Thank you very much.
thetravels
 
Posts: 2
Joined: 20. January 2010 00:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests