problems initializing php_printer.dll

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problems initializing php_printer.dll

Postby TheShwaGuy » 18. January 2010 18:23

Hello I am trying to have an intranet site print labels automatically to a printer, I have been searching the internet looking for php_printer.dll and I have found several version one I am assuming from what I read on the internet was an old version and not compatible with the latest version of XAMPP. one I cannot get to load at all, and the other came with a long list of dlls and I tried to get that working but with no luck.

I have copied the php_printer.dll from the latest build I could find and I get this error:

PHP Startup: printer: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match

I would need help on finding a version that is compatible, I have been looking on the net for a better part of the day and cannot find help.

Thank you,
TheShwaGuy
TheShwaGuy
 
Posts: 1
Joined: 18. January 2010 17:49

Re: problems initializing php_printer.dll

Postby Izzy » 18. January 2010 21:27

Seems that php_printer.dll is not yet compatible with PHP 5.3 and is why it is not included in XAMPP versions that include PHP 5.3.* - 1.7.2 and 1.7.3.

The last XAMPP version that contains this dll is version 1.7.1 which has PHP 5.2.9 - the last XAMPP with the 5.2 series of PHP.

You can download and install this 1.7.1 version of XAMPP or wait until there is a compatible version of the dll produced - seems that PHP are working on new Windows dlls but the time frame is unknown at this stage.

Older XAMPP version can be found here:
http://sourceforge.net/projects/xampp/files/XAMPP Windows
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests