Port 80: System

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port 80: System

Postby Loredivine » 17. January 2010 23:07

Hello, I just downloaded XAMPP in the hopes to learn PHP. I downloaded XAMPP, and once it was complete, felt the need to test the Apache Web Server. I clicked it to receive a message of Busy... Apache Started. Proceeded by no Running statement next to Apache, such as SQL. I checked the ports in the XAMPP Control Panel, and saw that Port 80 was taken up, by System. If anybody could help me with this, it would be greatly appreciated, cheers.

*Using Windows 7 Home Premium on a Dell Inspiron, I have full admin on account.
Loredivine
 
Posts: 3
Joined: 17. January 2010 23:00

Re: Port 80: System

Postby Izzy » 17. January 2010 23:23

Read the \xampp\apache\logs\error.log file to see why Apache can't start.

Do a reboot then try and start Apache to see if you get a green running indication in the XAMPP Control Panel.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Port 80: System

Postby Loredivine » 17. January 2010 23:27

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80

That was the error read in error.log
Loredivine
 
Posts: 3
Joined: 17. January 2010 23:00

Re: Port 80: System

Postby Loredivine » 17. January 2010 23:49

Also, I have installed on my computer Microsoft Visual Web Developer, for ASP.NET, might that be an issue?
Loredivine
 
Posts: 3
Joined: 17. January 2010 23:00

Re: Port 80: System

Postby Izzy » 18. January 2010 01:02

This (OS 10013) error message could be related to Windows Web Server IIS running and using port 80.

Try disabling this in the Control Panel and these instructions are for Vista so please adapt for W7:

To disable IIS go to
Start>Control Panel>Programs and Features
on the leftmost side you will find an option
Turn Windows features on or off
click on it and uncheck
Internet Information Services
click OK
and then restart your computer.

There was another method to stop IIS here:
viewtopic.php?p=153354#p153354

You may also need to disable User Account Control ( UAC ) to run a web server.

You may also want to allow XAMPP ports through any firewall or antivirus scanner ZoneAlarm etc. that you may have installed and running.

The full lists of ports can be found here:
http://www.apachefriends.org/en/faq-xam ... html#xpsp2

A forum search in XAMPP for Windows and a copy and paste of these keywords...
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions
...may reveal how popular this error has been and which also may include many solutions.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 93 guests