xampp 1.7.3 returns errors

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp 1.7.3 returns errors

Postby ragou » 17. January 2010 17:39

I've replaced older 1.7.2 with the newest 1.7.3 version and many scripts stopped to work.
If I upload them to remote server (PHP5) they work normally. How can I resolve the problem?
ragou
 
Posts: 4
Joined: 17. January 2010 17:04

Re: xampp 1.7.3 returns errors

Postby Izzy » 17. January 2010 23:26

Not enough detail in your post to work with.

Any error messages?
ragou wrote:I've replaced older 1.7.2 with the newest 1.7.3 version
How exactly did you do this replacement?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.3 returns errors

Postby ragou » 18. January 2010 01:57

This is an uploader
on a remote server it looks like this:
Image
the same script looks like this on the localhost:
Image
And the script is here:
http://imaloednovreme.com/151515/up.zip
ragou
 
Posts: 4
Joined: 17. January 2010 17:04

Re: xampp 1.7.3 returns errors

Postby Izzy » 18. January 2010 02:17

Your screen cap images are too big for the forum, please edit your post above and reduce the size to no bigger that 800 x 600, thanks.



Your script is not compatible with php 5.3 versions, just tested with XAMPP 1.7.3 and 1.7.2 both have php 5.3.* and both give the same errors that your second screen cap shows - your remote server may use php 5.2.* and may be why you get no errors.

So you will have to inform the script's author (ragou@*.bg - looks like you perhaps) to upgrade it for use with php 5.3.

Or revert to an XAMPP version with php 5.2.9 for example 1.7.1...
http://sourceforge.net/projects/xampp/files/XAMPP Windows
...which I have just tested with and it works like your first screen cap - you have to create a new folder in the htdocs folder called aaa for the script to use for uploading files, which will then remove another error message - there is no chmod in Windows Apache.

Or by using HotScripts.com perhaps, find another uploading script to use with php 5.3 as there are many well written scripts for this purpose in many of the web compatible scripting languages.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: xampp 1.7.3 returns errors

Postby ragou » 18. January 2010 15:21

Thanks.
First:
I've changed the resolution of the pictures.
Second:
I don't know how to change the script to be compatible with PHP5.3.
If it means to learn PHP again, I shall not. I am doing this for fun, not for money and I am too old to start over.
Anyway I thank you.
ragou
 
Posts: 4
Joined: 17. January 2010 17:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests