webdav on fresh install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

webdav on fresh install

Postby patfee » 15. January 2010 23:04

hi,
hope someone could help, as i cant find anyhting on google, nor the faq

i have installed xampp-win32-1.7.3.exe freshly and trying to work with webdav

but with no luck

which path should i use for starters?

localhost:81/webdav?

also, i dont understand why apache <webdav> port 81 states Free?

thanks
Patrick
patfee
 
Posts: 8
Joined: 15. January 2010 22:59

Re: webdav on fresh install

Postby Izzy » 16. January 2010 00:59

WebDav is enabled by default in XAMPP.

WebDav is configured in the \xampp\apache\conf\extra\httpd-dav.conf file.

There is a webdav.txt file in the \xampp\webdav folder which is in German.
(why a German language readme file is included in an English XAMPP release is not quite understood).
Also included in this folder is a test index.html file.
webdave.txt wrote:WEB-DAV für den gemeinsamen REMOTE-Zugriff
auf WWW-Dokumente über den Apache2.

Die Module mod_dav.so und mod_dav_fs.so auskommentieren
URL: http://localhost/webdav/
User: wampp Password: xampp
E-Mail-Adresse bei Dreamweaver angeben.
Lokales Directory: /xampp/webdav/
Roughly translated
google translation wrote:WEB-DAV for shared remote access
World Wide Web documents using the Apache2.

The modules mod_dav.so and mod_dav_fs.so are enabled.
URL: http://localhost/webdav/
User: wampp
Password: xampp
E-mail address in DreamWeaver specify or indicate.
Local Directory: /xampp/webdav/
So use http://localhost/webdav/ and it should return the test index.html file - of course Apache should be running before testing WebDav..

Port 81 will remain free until it is being used by WebDav in it's normal remote operation and is not used by WebDav to listen continuously like a web server, MySQL, email or an FTP daemon.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: webdav on fresh install

Postby patfee » 16. January 2010 07:42

Thanks for the extensive reply!

when i use http://localhost/webdav/ in IE, i see the index page without probs.

when i try to mount a networkdrive in the windows explorer (mount networkdrive), either using http://localhost/webdav/ or http://localhost:81/webdav/, the "dive" isnt found.

in httpd.conf, the following is (by default) uncommented:
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so

Include "conf/extra/httpd-dav.conf"

what am i doing wrong?

thanks
patrick
patfee
 
Posts: 8
Joined: 15. January 2010 22:59

Re: webdav on fresh install

Postby Izzy » 16. January 2010 09:34

Patrick, what Windows OS are you using?

Creating a WebDav network drive directly in Windows Explorer did not work for me either but both the methods below worked just fine.


1. Try and follow these instructions by typing cmd.exe in start>run... to get a command console in XP - just tested and the simple instructions work just fine.
Tip, change the x: to a drive letter of your choice.
http://smallvoid.com/article/winnt-webd ... drive.html
You can check the results in My Computer and My Network Places.


2. Another simple way is to do it in Internet Explorer:
Click on File>Open>Tick the box "Open as a web folder" >add http://localhost/webdav >add your default user/pass from my previous post or the webdav readme file.
You can check the results in My Computer and My Network Places.

You can create a shortcut on your desktop for quick easy access.
Remember that Apache and MySQL have to be running.



3. Yet another method is to download NetDrive from Novell, it's free and you can set up http://localhost/webdav through this nifty utility - I did not test this method.

Here is a link that may help with NetDrive configuration:
http://plone.org/documentation/kb/webdav

Good luck and please let us know back if you are successful creating your WebDav drive.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: webdav on fresh install

Postby patfee » 16. January 2010 10:15

The XAMPP compu is running XP PRO SP3

Just found out that on my other computers in the network the webdav works perfectly.
These compus run Win 7 ultimate

So, i think we can break it down to a `localhost` problem or an XP problem.

What i did notice in the http://smallvoid.com/article/winnt-webd ... drive.html`link, it states that XP can not mount different ports then port 80.
maybe thats the prob?
patfee
 
Posts: 8
Joined: 15. January 2010 22:59

Re: webdav on fresh install

Postby Izzy » 16. January 2010 10:21

I mounted the C:\xampp\webdav folder using http://localhost/webdav to drive X: on XP using methods 1 and 2 above with no problems with either method and WebDav in XAMPP uses port 81.

Is your firewall open for port 81 ?

As I said I did not check out NetDrive from Novell, I will leave that to you.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: webdav on fresh install

Postby patfee » 16. January 2010 13:46

works now now on XP compu too Izzy

had to install MS KB 907306

works now through explorer and net use

thanks for you help!!

Rgds
Patrick
patfee
 
Posts: 8
Joined: 15. January 2010 22:59

Re: webdav on fresh install

Postby patfee » 17. January 2010 22:02

izzy,

sorry, one more thing,
i cant copy "large" files from de "webdav server" to a workstation

i.e. copy of a movie trailer, 180mb, from my workstation to the server works flawless
copieing the file back from the server to my workstation generates an 0x800700df error.

it seems like an windows7 problem, as with my "server", running XP, i can copy any size from a networkdrive.

thanks for your support again

Rgds
Patrick
patfee
 
Posts: 8
Joined: 15. January 2010 22:59

Re: webdav on fresh install

Postby Izzy » 18. January 2010 00:26

patfee wrote:it seems like an windows7 problem, as with my "server", running XP, i can copy any size from a networkdrive.
Patrick, sorry this is beyond the scope of this forum to solve Win 7 OS issues.

Try searching the web using the keywords of what you know already about your issue, for example or similar:
windows 7 copy file size restriction error 0x800700df
and see what you come up up by way of others with a similar issue finding a solution - seems that the most common problem is with drives that are FAT32 formatted as opposed to NTFS formatted but they relate a much larger file size restriction and would not effect a file of 180mb.

I can't find anything related to copy file size restrictions in the Apache conf files but I could be wrong and a more experienced member may know of a tweak that I am not aware of.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: webdav on fresh install

Postby entr0py » 22. July 2011 16:48

I had a similar experience last night. I installed XAMPP on Windows Server 2003 and everything installed great. When I browsed to http://localhost/webdav/

I got a 404 error. I checked the file structure in C:\xampp\webdav\ and files did in fact exist (index.html and the webdav.txt file).

I tried from an external host also getting a 404. I'm not sitting in front of it at the moment, but i don't recall port 81 open on the server. Did the latest version turn off webdav by default for security concerns?
entr0py
 
Posts: 6
Joined: 22. July 2011 15:47

Re: webdav on fresh install

Postby Sharley » 23. July 2011 02:45

Look in the \xampp\apache\conf\httpd.conf file near the end of the file for this section
Code: Select all
# Distributed authoring and versioning (WebDAV)
# Attention! WEB_DAV is a security risk without a new userspecific configuration for a secure authentifcation
# Include "conf/extra/httpd-dav.conf"
Then uncomment it so it looks like this
Code: Select all
# Distributed authoring and versioning (WebDAV)
# Attention! WEB_DAV is a security risk without a new userspecific configuration for a secure authentifcation
Include "conf/extra/httpd-dav.conf"
Save the file and restart Apache

Make sure that you change the default password found in the \xampp\readme_en.txt file and in the webdav.txt file to help eliminate your webdav becoming a zombie.

The webdav configuration can be found in \xampp\apache\conf\extra\httpd-dav.conf file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: webdav on fresh install

Postby entr0py » 23. July 2011 03:09

Sharley wrote:
Make sure that you change the default password found in the \xampp\readme_en.txt file and in the webdav.txt file to help eliminate your webdav becoming a zombie.

The webdav configuration can be found in \xampp\apache\conf\extra\httpd-dav.conf file.


Thanks! I figured it was disabled but I haven't had a chance to look yet. And as to you comment about security, thanks but i intend on leaving it open on purpose! I'm using this as a example of poor security habits and showing what can happen. Thanks again!
entr0py
 
Posts: 6
Joined: 22. July 2011 15:47

Re: webdav on fresh install

Postby entr0py » 23. July 2011 03:31

Sharley wrote:Look in the \xampp\apache\conf\httpd.conf file near the end of the file for this section
Code: Select all
# Distributed authoring and versioning (WebDAV)
# Attention! WEB_DAV is a security risk without a new userspecific configuration for a secure authentifcation
# Include "conf/extra/httpd-dav.conf"
Then uncomment it so it looks like this
Code: Select all
# Distributed authoring and versioning (WebDAV)
# Attention! WEB_DAV is a security risk without a new userspecific configuration for a secure authentifcation
Include "conf/extra/httpd-dav.conf"
Save the file and restart Apache

Make sure that you change the default password found in the \xampp\readme_en.txt file and in the webdav.txt file to help eliminate your webdav becoming a zombie.

The webdav configuration can be found in \xampp\apache\conf\extra\httpd-dav.conf file.



I just made the configuration changes, but it doesn't seem that the DAV modules are loading. The config files all see to point to the correct locations and the modules are present.
entr0py
 
Posts: 6
Joined: 22. July 2011 15:47

Re: webdav on fresh install

Postby Sharley » 23. July 2011 03:33

You may also need to uncomment this line in the httpd.conf file
Code: Select all
#LoadModule dav_module modules/mod_dav.so
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: webdav on fresh install

Postby entr0py » 23. July 2011 03:48

Sharley wrote:You may also need to uncomment this line in the httpd.conf file
Code: Select all
#LoadModule dav_module modules/mod_dav.so


ah! That did it! Thanks!
entr0py
 
Posts: 6
Joined: 22. July 2011 15:47


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 69 guests