Apache won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start

Postby deadlyalive22 » 08. January 2010 16:14

Please help me on this guys, as I badly need to install this at my pc for my software project this semester.

heres the error log:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
deadlyalive22
 
Posts: 2
Joined: 08. January 2010 16:00

Re: Apache won't start

Postby rickh57 » 08. January 2010 17:19

It's telling you that there is some other process listening on port 80. Search through these forums for what apps to look for and stop.
rickh57
 
Posts: 25
Joined: 28. April 2005 17:12

Re: Apache won't start

Postby Izzy » 08. January 2010 23:34

deadlyalive22 wrote:heres the error log:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
http://www.apachefriends.org/en/faq-xam ... ml#nostart

Another program, for example and the most frequent is Skype, the Windows Server IIS or even another type of file server perhaps, is using port 80.

Use Port-Check in your XAMPP Control Panel to find out what it is, then take appropriate action to remove the offender from port 80 so Apache has exclusive use of it.

Skype can be configured to use another port and IIS can be stopped or even better completely disabled.

BTW you did not mention what version of XAMPP you are using or which Windows OS?



More helpful reading for new XAMPP users:
\xampp\readme_en.txt file

http://www.apachefriends.org/en/xampp-windows.html
http://www.apachefriends.org/en/faq-xampp-windows.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache won't start

Postby deadlyalive22 » 09. January 2010 14:08

Izzy wrote:
deadlyalive22 wrote:heres the error log:

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
http://www.apachefriends.org/en/faq-xam ... ml#nostart

Another program, for example and the most frequent is Skype, the Windows Server IIS or even another type of file server perhaps, is using port 80.

Use Port-Check in your XAMPP Control Panel to find out what it is, then take appropriate action to remove the offender from port 80 so Apache has exclusive use of it.

Skype can be configured to use another port and IIS can be stopped or even better completely disabled.

BTW you did not mention what version of XAMPP you are using or which Windows OS?



More helpful reading for new XAMPP users:
\xampp\readme_en.txt file

http://www.apachefriends.org/en/xampp-windows.html
http://www.apachefriends.org/en/faq-xampp-windows.html


thanks for that, skype is really the cause of my problem

i hesitated to try checking if skype is really using port 80 because when i used the xampp port-checker, skype was no longer to be seen there, so i didn't bother to try and check the connection settings of skype since it is not automatically started with windows.

thanks really for this. :lol:
deadlyalive22
 
Posts: 2
Joined: 08. January 2010 16:00


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests