Installing xsendfile on windows xampp 1.7.2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing xsendfile on windows xampp 1.7.2

Postby yvesbixer » 28. December 2009 16:56

I am trying to get xsendfile to work using the 1.7.2 release. I had it working with 1.6.7 using a precompiled binary (forgot exactly where I downloaded it), but that same file no longer works.

I think that the compiler changed from Visual C++ 2008 express to mingw. Is that true? Could that be the source of the problem?

Anyway, when I try it now, I get an error in my apache log that says:

httpd.exe: Syntax error on line 133 of C:/xampp-win32-1.7.2/apache/conf/httpd.conf: API module structure 'xsendfile_module' in file C:/xampp-win32-1.7.2/apache/modules/ is garbled - expected signature 41503232 but saw 41503230 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?

So I should be able to re-compile it using apxs, right? Unfortunately, I can't get that to work either. Putting the mod_xsendfile.c in the C:/xampp-win32-1.7.2/apache/bin directory for convenience, I then open a command line in the same directory, and run
apxs -cia mod_xsendfile.c

apxs -c -i -a mod_xsendfile.c

And the error I always get is:
apxs:Error: "C:\xampp-win32-1.7.2\apache\bin"\httpd.exe not found or not executable

You would think a path problem would be easy to fix. Unfortunately, I've failed. Things I've tried:
  • googling the error statement
  • putting c:\xampp-win32-1.7.2 in the $PATH variable
  • looking at permissions (appears globally executable)
  • stopping the apache server while I run the apxs command
  • using different flags

Nothing I have done seems to work. Any other ideas? Has anyone else gotten x-sendfile to work with the new xampp 1.7.2 (or 1.7.3) release?
Posts: 1
Joined: 28. December 2009 15:48

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests