1.7.2 -> 1.7.3 Update Path Issue

Problems with the Windows version of XAMPP, questions, comments, and anything related.

1.7.2 -> 1.7.3 Update Path Issue

Postby Izzy » 24. December 2009 09:08

@Carsten Wiedmann

Can you replicate this incorrect path issue if the upgrade path is not the default C:\xampp?

1. Ran upgrade 1.7.2 -> 1.7.3

2. Selected C:\xampp4 as the Destination Folder - existing 'out of the box' and fully functional XAMPP 1.7.2 version folder.

setup_xampp.bat file wrote:"I have found some updates.

Should I install them now?
(Please make sure that all XAMPP components are stopped!)

Your choice? (y/x=exit setup): y"


3. Hit enter to selected default y to install updates found.

4. Hit any key to finish.

5. Next select x to exit.

6. Go to C:\xampp4\php\pear.ini - see that the paths are all now C:\xampp44\

7. Checked all other paths in C:\xampp4 folder and see everywhere that all updated paths are now C:\xampp44


Selecting x to exit setup_xampp.bat without updating leaves all paths at C:\xampp4\

I discovered this when trying to run pear upgrade in a shell, which of course failed miserably and nothing else, of course, would run either.

Without running the setup.bat file my upgrade to 1.7.3 seems to be responding just fine.

Any edits I can make in any of the upgrade files to eliminate this issue if the Destination Folder location is not C:\xampp?


Important! - to other users who want to upgrade to 1.7.3 it is advisable to make a backup copy of your 1.7.2 installation folder first.
I made a backup copy of my xampp4 folder in my C:\ partition so I had C:\Copy of xampp4 that I could revert to for further testing of this issue.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Wiedmann » 24. December 2009 12:30

7. Checked all other paths in C:\xampp4 folder and see everywhere that all updated paths are now C:\xampp44

Ah, you have renamed the "xampp" folder. That's really a problem for the upgrade (have not tested this situation). Thanks.

(BTW: XAMPP (the xampp_cli) is also not working, if you rename the "xampp" folder to a name which contains a space like "my xampp". If a parent folder contains a space that's not a problem ("C:\program files\xampp") (well perl/mercury still doesn't like this).)

Any edits I can make in any of the upgrade files to eliminate this issue if the Destination Folder location is not C:\xampp?

You can open a XAMPP shell and execute this command (with the above paths as example):
Code: Select all
install\relocate_xampp.bat all "C:\xampp44" "C:\xampp4"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Izzy » 24. December 2009 13:18

Ah, you have renamed the "xampp" folder.
Not renamed as such as I installed 1.7.2 in to that C:\xampp4 folder.

You can open a XAMPP shell and execute this command (with the above paths as example):
Code: Select all
install\relocate_xampp.bat all "C:\xampp44" "C:\xampp4"
Thanks that quickly fixed the errant path issue.

Now when Apache is started this warning pops up 2 times
Warning
PHP Startup: Unable to load dynamic library 'C:\xampp4\php\ext\phpmime_magic.dll' - The specified module could not be found.
After running the setup_xampp.bat file to finish the upgrade it appears to remove the phpmime_magic.dll from the php\ext folder.

This dll is under the [PECL] section in the php.ini file and is uncommented in both 1.7.3 and 1.7.2.

The dll is in the 1.7.2 php\ext folder but appears to have been deleted from the php\ext folder after upgrading to 1.7.3 - there may be others that are missing now but as yet I have not checked and no other warnings have emerged.

Not running the setup_xampp.bat file, as I posted above, did not show this warning so the running of the update in the bat file perhaps is responsible.

Any clues why this should be and is there a fix other than copying over the dll from the 1.7.2 backup or commenting out the php.ini entry?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Wiedmann » 24. December 2009 13:30

Not renamed as such as I installed 1.7.2 in to that C:\xampp4 folder.

I mean with the EXE you can extract to "C:\" and after this step XAMPP is installed in "C:\xampp", and then you can rename this to "xampp4".

Or you have extracted XAMPP to "C:\xampp4" and now it's installed in "C:\xampp4\xampp"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Wiedmann » 24. December 2009 13:45

This dll is under the [PECL] section in the php.ini file and is uncommented in both 1.7.3 and 1.7.2.

Which line endings are you using in your "php.ini" (dos or unix style)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Izzy » 24. December 2009 13:58

Wiedmann wrote:...Or you have extracted XAMPP to "C:\xampp4" and now it's installed in "C:\xampp4\xampp"?
Not quite but I see where you may be confused as I used the word installed - I manually extracted the EXE to C:\xampp4 then ran the setup bat file to set the paths way back when 1.7.2 was first released, it is still in an 'out of the box' state.

Then I have just applied the 1.7.3 upgrade and changed the default Destination Folder from C:\xampp to C:\xampp4 or it would have obviously overwritten files in C:\xampp which contains the 1.6.8 version.

I have several versions of XAMPP installed in this way each to it's own numbered folder, so I am able to troubleshoot issues on the forum that may be version specific - I only ever extract the archive manually no matter what version I download, I like to have control of what goes where on my PC ;).


The php.ini file that was 1.7.2 and is now 1.7.3 has never been edited or saved and so is still in the state it was in after extracting from the archive.

My text editor is specified to Save As UNIX.
Editor Help Files wrote:Save As:
Saves document using original or specified file format. When "Original" is selected, the format (DOS/Windows, UNIX, EBCDIC, Mac) detected when a document is opened is used when it is next saved. Newly created documents use the DOS/Windows format when the option is set to "Original".
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Wiedmann » 24. December 2009 14:09

I manually extracted the EXE to C:\xampp4

OK.

The php.ini file that was 1.7.2 and is now 1.7.3 has never been edited or saved and so is still in the state it was in after extracting from the archive.

So the file is currently having dos line endings ("\r\n").

This dll is under the [PECL] section in the php.ini file and is uncommented in both 1.7.3 and 1.7.2.

The setup_script is (should) removing this entry during the upgrade.
Hm, for me that's working, regardless if XAMPP is in "c:\xampp" or "c:\xampp4" (but the file must have dos line endings). At the moment I'm not sure why this is not working for you (the original php.ini from 1.7.2 is having dos line endings).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 1.7.2 -> 1.7.3 Update Path Issue

Postby Izzy » 25. December 2009 23:02

Wiedmann wrote:...(but the file must have dos line endings). At the moment I'm not sure why this is not working for you (the original php.ini from 1.7.2 is having dos line endings).

Discovery.
Some text files in the xampp4 folder may have been edited and saved as UNIX after my PA seems to recall back in late August testing some PHP scripts that required various files in 1.7.2 be edited including the php.ini file before reverting to what was believed to be a default state

Unfortunately I was not informed of this seemingly "insignificant" fact and so was still under the impression that I was dealing with an 'out of the box' 1.7.2 version.

So after testing once again using a fresh extraction and setup of 1.7.2 (so a DOS saved php.ini file would be in use) the deletions generated by your setup bat file were effected - is there no work around in your code that would permit deletions no matter what line ending mode was used, were as I can see this perhaps being an issue for others?

Or perhaps a warning somewhere in the upgrade documentation to the effect that text files and in particular the php.ini file in 1.7.2 be saved, after editing, in DOS/Windows mode and not in UNIX mode, perhaps to prevent this issue or at least to inform if the above Warning message is received after upgrade and when starting Apache.



BTW, as expected, the path issue (C:\xampp44) is still evident after extracting and setup of a fresh instance of 1.7.2 to the C:\xampp4 folder - the correcting command you provided above had to be used once again.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests