After changing the password....

Problems with the Windows version of XAMPP, questions, comments, and anything related.

After changing the password....

Postby amanda099 » 12. December 2009 22:38

After changing the password to phpMyAdmin, I couldn't access it any longer and get the message:
phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


I did the system restore but it didn't help. I get the above message whether I use the old or the new password .
Please help ! What should I do ?

Amanda
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby Izzy » 12. December 2009 22:53

Missing support info - what XAMPP version and which Windows OS?

amanda099 wrote:After changing the password to phpMyAdmin...
How did you do that exactly?

amanda099 wrote:I did the system restore...
What system restore did you do?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: After changing the password....

Postby amanda099 » 12. December 2009 23:11

Hi Izzy ,
Version: XAMPP 1.7.2! on Windows XP Professional
I went to the page http://localhost/phpmyadmin/
then clicked on Change password
then typed and retyped the new password
(I did click on Generate but deleted the newly generated password immediately)
then I clicked Go

What system restore did you do?

I restored the computer to the earlier time 10/12/2009 using All Programs > Accessories > System Tools > System Restore

What did I do wrong ?
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby Izzy » 12. December 2009 23:16

Try this:
Check in the XAMPP Control Panel that MySQL is running then double click (run) the \xampp\mysql\resetroot.bat file then try and access phpMyAdmin using root user with no password.

If successful then create your password again by following the method below and retry access to phpMyAdmin.

You can set the root user password from the Security menu item in http://localhost/index.php after running the above bat file to clear any existing passwords.

This XAMPP method is preferred over the one that you used in phpMyAdmin.

Please let me know back if you had success.

BTW a system restore will have no effect on the databases stored in MySQL including the database the passwords are stored in.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: After changing the password....

Postby amanda099 » 12. December 2009 23:20

Give me an hour Please Izzy ! Some Family Issue !
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby amanda099 » 13. December 2009 01:41

Izzy
I did what you said:
while MySQL was running, I double clicked (run) the \xampp\mysql\resetroot.bat file
then I restarted MySql using XAMPP Control Panel.
then I was successful in accessing phpMyAdmin immediately using root user with no password .

But then I restarted the computer (I don't know why I did that but I did).
Now I can't access phpMyAdmin anymore (using root user with no password) and the message comes back:
phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


I did try the whole process all over again with no success:
while MySQL was running, I double clicked (run) the \xampp\mysql\resetroot.bat file
then I restarted MySql using XAMPP Control Panel.
......

Waiting for your instruction. Amanda
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby Izzy » 13. December 2009 02:14

Follow the procedure again but minus the reboot.

Then set your root user password in the Security menu item on the XAMPP Welcome Demo Page at http://localhost/xampp/index.php

Also check the \xampp\apache\logs\error.log file at the time you got the error.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: After changing the password....

Postby amanda099 » 13. December 2009 02:28

I did follow the procedure again but minus the reboot and still received the same error message.
Here are the last lines in the \xampp\apache\logs\error.log file :

Terminating on signal SIGTERM(15)
[Sun Dec 13 14:04:09 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Dec 13 14:04:09 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Dec 13 14:04:09 2009] [notice] Digest: done
[Sun Dec 13 14:04:24 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Sun Dec 13 14:04:24 2009] [notice] Server built: Jul 22 2009 11:35:54
[Sun Dec 13 14:04:24 2009] [notice] Parent: Created child process 3260
[Sun Dec 13 14:04:28 2009] [notice] Digest: generating secret for digest authentication ...
[Sun Dec 13 14:04:28 2009] [notice] Digest: done
[Sun Dec 13 14:04:31 2009] [notice] Child 3260: Child process is running
[Sun Dec 13 14:04:31 2009] [notice] Child 3260: Acquired the start mutex.
[Sun Dec 13 14:04:31 2009] [notice] Child 3260: Starting 150 worker threads.
[Sun Dec 13 14:04:31 2009] [notice] Child 3260: Starting thread to listen on port 443.
[Sun Dec 13 14:04:31 2009] [notice] Child 3260: Starting thread to listen on port 80.
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby Izzy » 13. December 2009 02:34

The error log is OK.

The error message covers a multitude of issues and pinning it down may be a problem.

Did you try and set a password for root in the Security page?

If so then try and access phpMyAdmin using root and the password you set.

Also clear your browser's cache first.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: After changing the password....

Postby amanda099 » 13. December 2009 02:58

Izzy
Hahaha , I went to Tools > Internet Options > Browsing history > Delete... and deleted them all (Is that what you call "clear your browser's cache" ?)
Then I followed the procedure again.
Then I set the new root user password from the Security menu item in http://localhost/index.php after running the above bat file to clear any existing passwords. Actually I set the password for MySQL SuperUser. It seems that MySQL and phpMyAdmin use the same password ! ??

It works like a charm now !
It's 02:55 am in Denmark now and I need to sleeepp. I will read your post tomorrow. Thank You so much for reponding so quick ! Amanda .
amanda099
 
Posts: 41
Joined: 02. September 2009 15:05

Re: After changing the password....

Postby Izzy » 13. December 2009 03:20

Usually the cache is under the Temporary Internet Files label or similar wording.

Your Browsing History is the URI link addresses from the address bar that are saved.

Clearing the browser's cached files will prevent you being given an old file instead of a new file from the web server which may have happened with the error message page you kept getting after making the required corrections.

When working at localhost level you should clear your browser's Temporary Internet Files (the cache) often to prevent this kind of behavior.

That's correct, the Super User is root for both MySQL and phpMyAdmin.

I am pleased it is now working for you.

Good luck Amanda.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests