Something is wrong with the XAMPP installation :-(

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Something is wrong with the XAMPP installation :-(

Postby Alistair » 11. December 2009 09:21

My index.php has gone mad. It was the only way I could make my footer work, have it in the index.php file, now though it's gone mad and that's what it shows. Goes without saying I lost my footer, but I fear I might have other repercussions too, how to restore it to how it was?

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(
Alistair
 
Posts: 10
Joined: 11. December 2009 09:13

Re: Something is wrong with the XAMPP installation :-(

Postby Alistair » 14. December 2009 09:01

No one has ever seen this error message before then? Should I reinstall Xampp? Please tell me not to, I fear I'll lose all my work...
Alistair
 
Posts: 10
Joined: 11. December 2009 09:13

Re: Something is wrong with the XAMPP installation :-(

Postby Izzy » 14. December 2009 09:32

Missing support info - what XAMPP version and which Windows OS?

Your first post I don't understand.

The code you have posted is the XAMPP index.php file and shows the error message when there is no php parsing by the Apache server.

Use your own index.php file not the xampp index.php for your footer as the sole purpose of the XAMPP index.php file is to redirect to the index.php file in the htdocs\xampp folder.

How did you install XAMPP?

Any clues in the \xampp\apache\logs\error.log file?

Is Apache and MySQL running - check using the XAMPP Control Panel.

More helpful reading for new XAMPP users:
\xampp\readme_en.txt file
or
http://www.apachefriends.org/winxampp/readme_en.txt

http://www.apachefriends.org/en/xampp-windows.html
http://www.apachefriends.org/en/faq-xampp-windows.html
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Something is wrong with the XAMPP installation :-(

Postby Alistair » 15. December 2009 18:24

Hi, I'm using the latest version of Xampp and Windows XP service pack 3.

You say there is no php parsing by the Apache server, that I really don't understand, but if it's no cause of concerne it's fine by me.

What do you mean by my own index.php file? I'm a bit confused, how many are there?

I installed Xampp following the instructions and it's worked brilliantly for months, and it's still working great. My only worry is that I lost my d^mn footer.
Alistair
 
Posts: 10
Joined: 11. December 2009 09:13

Re: Something is wrong with the XAMPP installation :-(

Postby Alistair » 16. December 2009 08:38

Hey, I found the index.php file you mentioned, sorry sorry my mistake I didn't see it and used the xampp one. Thanks
Alistair
 
Posts: 10
Joined: 11. December 2009 09:13

Re: Something is wrong with the XAMPP installation :-(

Postby dendic3840 » 18. January 2015 20:28

I have this problem and re-installed xampp but continue to have the same problem. I read the responses but I fail to understand this index.php issue. Here is the error from my error log.
[Sat Jan 17 13:51:46.436302 2015] [:error] [pid 4420:tid 1724] [client ::1:60037] script 'C:/xampp/htdocs/xampp/imdex.php' not found or unable to stat
Please help me I'v been stuck on this problem for a week.
dendic3840
 
Posts: 2
Joined: 18. January 2015 20:14
Operating System: windows 8.1

Re: Something is wrong with the XAMPP installation :-(

Postby Nobbie » 18. January 2015 23:06

dendic3840 wrote:I have this problem and re-installed xampp but continue to have the same problem. I read the responses but I fail to understand this index.php issue. Here is the error from my error log.
[Sat Jan 17 13:51:46.436302 2015] [:error] [pid 4420:tid 1724] [client ::1:60037] script 'C:/xampp/htdocs/xampp/imdex.php' not found or unable to stat
Please help me I'v been stuck on this problem for a week.


DO NOT double click index.php in your explorer, instead enter a valid URL into the browser (i.e. http://localhost/xampp).

Anyway, you have a typo in your message: "C:/xampp/htdocs/xampp/imdex.php". File imdex.php is unknown.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: Something is wrong with the XAMPP installation :-(

Postby dendic3840 » 19. January 2015 16:23

This is not error but the response back from apache when I typed localhost.
dendic3840
 
Posts: 2
Joined: 18. January 2015 20:14
Operating System: windows 8.1

Re: Something is wrong with the XAMPP installation :-(

Postby Altrea » 19. January 2015 17:32

no no never.
There is definitely no imdex.php reference in the default configs, only index.php
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests