New Setup-Apache not starting

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New Setup-Apache not starting

Postby karin42 » 08. December 2009 23:49

Hi All,

I'm having some trouble starting Apache on my Windows machine (Vista). Here are the steps I took:

1. Downloaded Zip file
2. Extracted to c:\ folder
3. Ran setup_xampp.bat
4. Choose the drive option, left everything else as default
5. From setup_xampp.bat, I entered the Control Panel
6. exited out of setup_xampp
7. In the Control Panel I clicked Start for Apache
8. The status says Apache Started but the Start Button Does not change to Stopped
9. I clicked Post-Check and it says:
Apache (HTTP) 80 SYSTEM
Apache (WEbDAV) 81 free
Apache (HTTPS) 443 free
10. There don't seem to be any services in the SCM
11. The Error log said:
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address

I'm an administrator on my system : Windows Vista. does anyone know what else I need to do to be able to start my Apache service? Any help would be greatly appreciated.

thank you all,

Posts: 1
Joined: 08. December 2009 23:21

Re: New Setup-Apache not starting

Postby Wiedmann » 09. December 2009 00:22

9. I clicked Post-Check and it says:
Apache (HTTP) 80 SYSTEM

There is already a server like IIS or Skype running. Stop this server and you can start Apache.
AF Moderator
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: New Setup-Apache not starting

Postby etxTrey » 09. December 2009 05:54

Hi Karin,
I just installed xampp on Win7 x86 (which has many similarities with Vista)
and also ran into the (OS 10013) error.

I think Wiedmann is correct that port 80 is already claimed.
I have much of the IIS stuff installed, but haven't turned anything on explicitly.

In \xampp\apache\httpd.conf (a local .conf would have been better, but I'm lazy),
I changed to
So Apache is listening on the loopback address (localhost) on port 8080,
instead of port 80.

Apache was then able to start right up.

One other thing should be mentioned...
if you want to install apache as a service,
depending on your UAC settings (and maybe the phase of the moon),
you may need to do so as Administrator.

Note that there is only one "Administrator", though there may be many "administrators".
They are not the same. Elevated-run has various "gotchas".
I suggest that you actually log in as Administrator, then install.

(If your system claims not to know "Administrator", it's lying!
You can activate the built-in Administrator account from a cmd window:
c:> net user Administrator /active:yes
Be sure to set a password immediately.)
Posts: 1
Joined: 09. December 2009 05:25

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests