Error Message, Please help.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error Message, Please help.

Postby tinkertron » 04. December 2009 22:18

Access forbidden!


--------------------------------------------------------------------------------

New XAMPP security concept:

Access to the requested directory is only available from the local network.

This setting can be configured in the file "httpd-xampp.conf".


--------------------------------------------------------------------------------


If you think this is a server error, please contact the webmaster.

Error 403
tdcj.homeip.net
12/4/2009 3:10:51 PM
Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0

Can some explain more better what is causing this error and what do I need to do to fix it?
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52

Re: Error Message, Please help.

Postby Izzy » 04. December 2009 22:36

Missing support info - what XAMPP version and which Windows OS?

What are you typing in your browser's address bar?

Does http://localhost take you to the XAMPP Welcome Page?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Error Message, Please help.

Postby tinkertron » 05. December 2009 05:00

I'm using the most current version of XAMPP 1.7.2
XAMPP 1.7.2!
Congratulations:
You have successfully installed XAMPP on this system!
Now you can start using Apache and Co. You should first try »Status« on the left navigation to make sure everything works fine.



For OpenSSL support please use the test certificate with https://127.0.0.1 or https://localhost

And very important! Big thanks for help and support to Nemesis, KriS, Boppy, Pc-Dummy and all other friends of XAMPP!

Good luck, Kay Vogelgesang + Kai 'Oswald' Seidler + Carsten Wiedmann
---------------------------------------------------------------------------------------------

I'm running Windows XP SP3. (everything is a fresh install as of today, and all updates have been apply)

I'm using DynDNS services for my IP. My port "80" for my routers are open, and also for my firewall. The only thing I haven't done yet, which might work is to totally disable my firewall, and see what happens.
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52

Re: Error Message, Please help.

Postby tinkertron » 05. December 2009 23:22

Update:

I'm not sure how I got it since I did serval little things, but I think I know how to fix this issue.

What I did: I opened the XAMPP welcome screen and then into the security tab, where I saw a link
The green marked points are secure; the red marked points are definitively unsecure and the yellow marked points couldn't be checked (for example because the sofware to check isn't running).

To fix the problems for mysql, phpmyadmin and the xampp directory simply use
=> http://localhost/security/xamppsecurity.php <= [allowed only for localhost]

Here I set the username and password for both my apache server and mysql

After all that, I was able to access my webpage
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52

Re: Error Message, Please help.

Postby tinkertron » 07. December 2009 00:17

Update to the update: it has happen again... I don't know what is causing this to happen, but it's happening... I made sure all the service is started but getting the same error as above.
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52

Re: Error Message, Please help.

Postby Wiedmann » 07. December 2009 00:50

Error 403
tdcj.homeip.net

Why want you access the XAMPP demopage with this URI, and not with "localhost"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Error Message, Please help.

Postby tinkertron » 07. December 2009 03:25

I get this error cause it's not opening the index.html page. localhost works fine, but it the domain that it won't reach the server. I'm try to view the site through the domain so I can that it's working.
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52

Re: Error Message, Please help.

Postby tinkertron » 07. December 2009 03:37

OMG... I got it firgure out now... Something so simple that I can't believe that I find the problem... OK this is what I found, You need to move the index.php out of the htdocs folder. In this case I simply move it to my desktop, not sure if I will need it in the future, so i kept it and just move it out of the folder. How wierd is that?
tinkertron
 
Posts: 13
Joined: 25. November 2009 05:52


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests