Can't log in to my phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't log in to my phpMyAdmin

Postby creacon » 04. December 2009 18:58

I changed the password for phpMyAdmin, and now I can't log in with either the old or the new password. I get the following page displayed;

phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


I searched for .log files, and looked at the access.log and error.log in the C:\xampp\apache\logs folder, but I have no idea what the entries mean, nor how to fix them in accordance with the above error message. In C:\xampp\security I found the file, "mysqlrootpasswd.txt" and it has the old password in it.

Also, I can't execute any of my web pages that use MySQL. I get the following error:
[quote][Warning: mysql_pconnect() [function.mysql-pconnect]: Access denied for user 'root'@'localhost' (using password: YES) in C:\xampp\htdocs\IOD\Connections\LogIn.php on line 9

Fatal error: Access denied for user 'root'@'localhost' (using password: YES) in C:\xampp\htdocs\IOD\Connections\LogIn.php on line 9
/quote]

Can someone please help me resolve this problem? I'm really in trouble.
creacon
 
Posts: 36
Joined: 21. August 2009 19:14

Re: Can't log in to my phpMyAdmin

Postby Izzy » 04. December 2009 22:21

Stop MySQL then you could try and reset your password using the \xampp\mysql\resetroot.bat file.

Start MySQL again then try and access phpMyAdmin without a password for root user to see if it works.

If you can access phpMyAdmin with user root and no password, then in the Security link off the XAMPP Welcome Page you can once again set a root user password for MySQL\phpMyAdmin.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Can't log in to my phpMyAdmin

Postby creacon » 05. December 2009 00:04

Thanks for the help. I did what you said, and now it works. I had run that .bat file several times, but in my ever encreasing senility, I forgot I had to turn off MySql and restart it. Everything's fine now, and thanks a million.
creacon
 
Posts: 36
Joined: 21. August 2009 19:14


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests